The Lost Heir 3: Demon War Bugs and Errors


#103

It worked once, but it shut off again right after. Is there any way to fix this? (I’ve already tried deleting it and reinstalling.) I’m on an iPad, if that helps.


#104

Don’t know if this is already reported or not


#105

So I know I posted about this before, but I’m still trying to get it t work. The saves don’t load, it says maximum call stack exceeded. I’m on an iPad, so is there any way at all I can fix this, or is I think just stuck like that?


#106

Send as much detail to support AT choiceofgames.com I hope they can get it working for you soon.


#107

Alright, thanks. Appreciate it


#108

The steam save problem still persists.


#109

If you’re still having trouble, try these steps:

  1. First, open up LH2. Restart the game and try to restore from LH1. Make sure you see your LH1 and LH2 saved games there.
  2. Next, reboot your computer and try LH3 again. Rebooting will completely restart Steam Cloud, which may allow LH3 to download the saves that way.
  3. Still not working? On the LH2 restore menu there’s an option to “Retrieve saved games online from choiceofgames.com.” If you use it, LH2 may offer you another option to “Upload saved games to choiceofgames.com.” Then, back in LH3, you can try retrieving them from choiceofgames.com again.

If the problem continues after that, please send an email to support detailing where that process fails.


#110

I noticed a bug with my last two playthroughs. Right before the final fight with K’Girr and Zusak,level 1 paladins will be healed by their god, but level 2 paladins are not healed.


#111

There is something I like to point out in LH3 everytime I choose an answer or next the page there is always a little lag ,like after I click the next page button or choice there is always a hang time for 2 seconds can you fix that please? Or I’m the only one with that problem?


#112

Most likely just you.


#113

I have heard of this too. Are you on Android? This is out of my hands, but I will help to follow up to see what is happening.


#114

I’m using Android ,if you can please fix it thanks


#115

I’m using Android and don’t have this problem.


#116

@Frogs
It’s only possible if you don’t have Theo/Thea in your party. There is no way for them to leave otherwise (if you drink a lot it says the guard takes them back to camp but apparently it still counts it like they stayed in the code, probably a bug)


#117

I chose to save the Red (Gill) at the end of the second game. At the end of this game, he didn’t contribute at all to my Battle Results, and he didn’t get any mention at all in my Epilogue. I also couldn’t leave any money to him in my will, and I don’t think I could give my Demonstone to him when Synden was injured.


#118

@TheDrake
Bug report: @Lucid in part 3 when your child is kidnapped there is a option to search for tracks that requires 2 level ranger. I tried it with a level 4 ranger and still failed the stat check.


#119

Very little is known about the Som’Reth. It has been eons since they all vanished, leaving behind their knowledge of demon summoning. It makes searching through their books even more difficult.You spend several minutes trying to find the right book. (Needed 85 Perception, or 2 Levels in Sage, or 4 Levels in Bard)

I was on a sage play through, and my sage level was 3.


#120

In interlude.txt, the Unknown will still abandon you if you aren’t sufficiently evil.


#121

That’s actually could be part of the lore: the unknown by nature is an evil god, thus it might betray a good MC if they’re overly dependent on it at the right moment. However it does grant the MCs a passage to heaven to join it, making it the most mysterious god of all.


#122

As @Lucid has said that it doesn’t care about your alignment, I’m calling this a bug until stated otherwise.

Remember that while it’s “evil,” its whole schtick is that it isn’t playing the same alignment game that the other gods are.