Seas of Malice (Character Creation + 3 locations partially done, WIP)

I posted about this game a few months ago, and I’ve finally got around to writing up the first scene. The game would be much like Sunless Sea, where the player may journey around an open world and complete little storeylets in each location, with a few overarching storylets taking place over multiple locations. I’ve written the first scene, up until the player receives their ship. Anybody is welcome to play. The game is very rough, but I’ve stamped out a fair few errors and the game should run smoothly, for the most part.


Now with saves!
Edit: DO NOT PLAY THIS ON INTERNET EXPLORER (Why would you anyway?) There is a game-stopping, unfixable bug with *input_number on internet explorer, but not any other browser.

Please send feedback, and be critical. “The game is nice,” doesn’t help me at all, but neither does “this game sucks, go kill yourself.” Please keep criticism constructive.


When I clicked Show Stats:
choicescript_stats line 4: Non-existent variable 'leadership'

Oops, an extra scene slipped in. I’ll remove it.

Seems like you can’t change your profession

Also, there seems to be a loop here that you can’t get out of.
When you click Next, it goes back to the same thing.

There also isn’t a way to escape the conversation with the blacksmith

This game does show promise and I would like to beta test

Apparently, I accidentally overwrote my custom stats page when I updated Choicescrtipt master. I’ll have to create it again.

It seems that it does that whenever you try to buy something

Festival_of_Lights line 1940: Invalid expression, couldn’t extract another token: .5

Updated, stats screen should work now, conversations should be escapable.
Unsure about the last one, I’m going to do some digging. Say if the problem persists after.

You can use the edit feature add/change your comments, you know.

It’s better to keep everything in one place.

Same problem with that one, still locked.

Strange, it’s working fine for me. I’ll update the link.

This is just weird then, I am doing it right now. I will try to reload and restart it in order to test it out again.

Also, In the switching profession page after inheriting the family stuffs, it is basically locked on the page for me. Can’t do anything with the choice. I might have to restart.

1 Like

THAT’s a problem with the code, just fixed it. I seem to forget to add escape options a lot.

Tried the options again. The website told me that in that choice, the code was non-existant. Thought you might want to add it soon.

Was it the “Non-existant variable “set””?

Festival_of_Lights line 720: Non-existent variable ‘set’: The website code here.