"Permission Denied" from running the Index.html from a Notepad++ edit

I’m having trouble with editing ChoiceScript with Notepad++ when I open and edit the code (within the workplace) with this program and run the index.html file it comes up with a “Permission denied” error without any extra info.

This does not occur if I use the basic Notepad and once I use Notepad++ the only way that I have discovered which allows my to fix this is to delete the entire choice script folder, reinstall it and paste the code into the basic Notepad…

Is this an encoding error? Am I just being a clown? Is something bamboozling me?

Many thanks for and replies.

Edits -

  • As a note I’ve been using internet explorer to test my code,
  • Fixed it,
  • I’m not opening the html file with Notepad, only the .txt scene files,

Umm… actually, when writing (or creating, making, whatever) a game, you don’t need to edit the index.html.

Your workplace is on .../mygame/scenes/ directory and you only edit all the .txt files inside.


Well, there it is. Firefox is the only way to test the code, currently.

1 Like

ah no no I wasn’t editing the index file :sweat_smile:

I was running that because that was how I’ve been running my code for tests. I’ve been editing my scene .txt files don’t worry about that.

:robot:
*perfect facepalm

ah I fixed it - turns out that somehow after I use Notepad++, Windows 10 “blocks” the index.html file… just had to unblock it in the file properties.

Thanks anyway Szaal :smiley:

You don’t need to open the index file with Notepad to test your game, really.

Just open it with Mozilla Firefox.

2 Likes

ack, did you think the same @Szaal ? is that why you perfectly facepalmed?

Sorry I should have been clearer but in my sleep deprived state I thought I was making perfect sense, sorry.

I’m running the index.html file with internet explorer (instead of firefox) I’m not opening it with Notepad. Not editing the index.html file at all…

in any case I’ve fixed it :smiley:

2 Likes