Nothing is working! Permission Denied


#1

Hello.
I know there are already topics on this Permission Denied but I have tried every method I could find.

I’ve unblocked the the compressed file before extracting, I’ve tried to re-download the whole package and I’ve checked and unchecked the the read-only boxes. I’ve tried it together and separately but it still stays the same.

The ‘Permission Denied’ happens every time I make a change using Notepad++ before entering the test mode. It didn’t act like this when I was using just regular notepad but the problem with continuing to use notepad is that I can’t figure out errors in the future because it doesn’t show line numbers so i really want to use Notepad++.

Please help me and thank you for listening.


#2

Okay, assuming you’ve been through the huge slightly wandering posts…

Have you considered it might be the text files themselves? If you right click on the text file and click properties, then go to the security tab. Does it say you have full control when you click the users list, because notepad is automatically an admin, but notepad++ will just be a basic user.


#3

It says that it has full control but it’s still not working.


#4

Okay, am pretty much failing with good ideas… Couple of bad ones…

Did you install notepad++ with admin mode? Because sometimes things install badly otherwise.

Did you restart your comp after changes permissions? Some may not take effect until restart even though they say they have?

In a worst case scenario… I recently switched from notepad++ to Sublime. I have found it better, although you do have occasional reminders that you should be paying for it, the evaluation period is infinite…


#5

Hello there xdCakexd. I am personally pretty new at this, and have been using these forums frequently for troubleshooting. I ran into I think is the exact same problem. Personally I was trying to open my game using Internet Explorer, and much to my frustration, I was denied access to my own file. After trying everything mentioned (as I believe you are now doing.) I found a solution of my own. Put simply, Internet Explorer didn’t cut it. I downloaded firefox, and was able to test my game within it perfectly fine. All my editing is done in Notepad++, but that was just a personal choice because it points out line numbers, which is incredibly helpful for debugging. I actually came on here to solve another problem of mine, but saw your issue and made this account to help and see if this was the same thing I encountered.


#6

@ Pyromanci
It seems that the worst case scenario happened. I switched it to Sublime and it looks to be working fine now.
Thank you so much for your help Pyromanci!
@TechDragon610
I tried both firefox and internet explorer and they both produced the same result. The issue has been solved now and I really appreciate you trying to help me. Thank you!


#7

Well at least you got the kinks worked out. Good luck on your coding endeavors.