Permission Denied?! What Permission?


#1

I was developing a game that I was very excited about, but then I tried to change the mygame JS file to add new scenes. For some reason, I cannot change the scenes from anything but the default consisting of only startup, animal, variables, gosub, ending, and death. Any change whatsoever causes a message to appear when I run through my game that says “Permission Denied.” It has no sort of explanation or any suggestions on fixing it. Those are the only two words in the box, and then my game freezes with a little bar moving around that says it is loading even though it is not. Changing the mygame is the only thing that gives this error. Is there something I have to do in order to be granted permission to change the mygame? I have already tried redownloading the latest ChoiceScript, copying the mygame and duplicating it, and copying and pasting all of the coding from the entire folder and creating an entirely new folder of the entire ChoiceScript. I have no idea how to fix it.


I'm having trouble with the scene_list command
#2

I’m not very experienced at these things but… Did you delete anything in the “Web” folder? Such as the “ui” and “Util” Or the navigator (I think it might have something to do with it…)? I don’t have any problems with these kind of things. If these don’t work, try rebooting. Rebooting usually fixes some errors. Such as Programs are in use when they are not.


#3

Don’t know for sure.

  1. Does changing stats in mygame.js work?

  2. What web browser are you using?

  3. If you’re on Win7 (maybe Vista and Win8 too) make sure to “Unblock” the zip file before you extract it. Right click>Properties>Unblock (I think).


#4

@Happy What do you mean by “rebooting” it? Like restarting my computer? Or closing the folder and reopening it? I have done both dozens of times. I didn’t delete anything. Most of the documents I have not even touched other than when I copied and pasted them.

@Reaperoa I suppose my browser could be the issue. I am on Internet Explorer 7 as far as my Internet browser goes… I tend to get spammed with messages saying that my version is not supported… by anything. I’ll try unblocking it! I believe I am on one of the Windows that you listed, but I don’t know off the top of my head! Changing stats works. As far as I can tell, adding scenes is the only thing that does not. Every other error I have run into, I have been ale to fix myself, and I have yet to encounter something else that will not work after laboring away for a while.

EDIT:
@Reaperoa Thank you SO MUCH! Unblocking worked!!! I am so happy to be able to continue AT LAST!!!

How do I get rid of this thread, as it is not needed anymore?


#5

The monitors will close it soon