"Permission Denied" when I make a new scene


#1

I’m new at this, and yesterday I tried to make a new scene for the first time. I made a text file, added it to scene_list in the startup file, and found that it gave me a “Permission Denied” error every time I tried to follow that path. The only scenes it could go to were the sample ones included with the ChoiceScript download. (I can change and rename those scenes, and it will still work. However, if I bring up their properties and choose to “unblock” them, they’ll stop working as well.)

I dug through previous questions on the forum until I found people talking about editing the scene list in mygame.js. Do you need to do that to create new scenes, even though the tutorial doesn’t mention it? I went to the wiki and looked up mygame.js, and opened it in Notepad so I could edit it, but it didn’t look the way the wiki said it would. What should I do?


#2

Did u add create scene at your startup file?? That might help


#3

I have *scene_list in my startup file. Is that what you mean, or is there something else?


#4

@SamLienhard This has happened to me quite a while ago and I don’t remember the cause exactly, but I think it was because I messed up the file extraction.

Download choicescript again. Don’t close the extraction software until the extraction is 100% done. See if that helps.

EDIT: *scene_list is enough.


#5

You may have opened the game with the wrong index file? Use the one inside mygame.


#6

@DSeg I downloaded it again and kept it open until the extraction was complete, but the problem remains.

@MutonElite That’s the one I’m using.


#7

Okay, let’s try tagging a few experts then. @CJW @dfabulich @jasonstevanhill


#8

From what I’ve found, If the scene you created isn’t within the scenes folder in mygame, then it gives a similar error. Other than that I’m not quite sure where it would come from.


#9

One easy workaround is to write over the existing scenes that come with the file. That way the structure is the same an everything works, only your scenes are called “animal” or “gosub” or whatever they are.


#10

@BlazedStorm Could there be something that makes it think the scene is somewhere else, even though the file is in the folder?

@distracteddad I can rename them, so that wouldn’t be a problem. The frustrating part would be if I wanted more scenes than the existing ones. I guess I’d have to make copies of the existing scenes.


#11

Yeah I was just talking about a short-term workaround if you want to see you work in progress. You don’t have to rename anything; you’ve got 6 or however many scenes ready to go. Just paste your text into them.

It sounds like you’re working off an old version of things. There’s no mygame.js anymore. You just name your first scene “startup” and then have the scene_list with the subsequent scenes listed seriatim.


#12

That’s what I thought, but when it wasn’t working, I tried to look it up to see if anyone else had the same problem. That’s where I found stuff about editing mygame.js and thought maybe I needed to do that.


#13

Maybe walk us through exactly what you’re doing and where you have what? The only things you ever really need to bother with is the index file within the mygame folder and the text files within the scenes folder. Maybe paste in your code from startup as well.


#14

This sounds like the issue with Windows 7 “blocking” the Choicescript files. In your original post, you mentioned right clicking the files and unblocking them, but that this did not work.

Did you “unblock” the original zip file before extracting the files, or did you unblock the files after extracting them?

I believe you need to unblock the original zip file you downloaded (right click -> Properties) and then extract the contents of the zip file again. You should then be able to create scenes in the new location without experiencing the “Permission Denied” error.


#15

@byronmcsteele Thank you!!! That fixed it!