ChoiceScript Newbie has Permission Issues


#1

Hi all!

I’m working on a ChoiceScript game at the moment. While I don’t want to spoil anything, it is an amazing game surely to be lauded for generations to come. The plot demands emotional investment; the characters are relatable yet magnificent; and the world sounds, smells and even tastes real. This masterpiece has but one flaw.

It won’t load.

After I edit the startup script, I get an alert that says “Permission denied” every time I load the index.html file. Then, the loading animation plays and nothing else happens. Here’s what I’ve tried:

-Checking my indents/spacing
-Not using Google Chrome
-Changing startup’s file name and then adjusting the references in the HTML code accordingly
-Sobbing wretchedly

What am I doing wrong?

Thanks :-bd


#2

Sobbing wretchedly! LOLOLOLOL
Have you tried using Firefox?


#3

Uh, if I recall that’s an issue to do with the unzipping of the files.
Was it @Reaperoa who had a solution?

I *think* it was fixed by unzipping it as an admin or something along those lines.


#4

Did you make sure that you went on to properties and ticked the little box thing? Sorry if I’m being vague, but that happened to me a long time ago and that’s what I was doing wrong.
Good luck, I’m sure you’ll fix it :slight_smile:


#5

First, I don’t remember the details of this problem, however, I do remember where I put the solution, so, straight from the wiki:

If you are using Windows 7 (and possibly Vista), when you download the .zip file, right click on it and select properties. At the very bottom of the properties window there will be a button that says Unblock. Select that button and press OK before extracting. This will help prevent a possible error that can come from Windows “blocking” the files because they can from a different computer. Then open the file (double click) and at the top of the window there will be a button that says Extract All Files. Click it, then on the window the pops up, select Browse then Desktop (or wherever else you want the game). After it done extracting there will be a new folder (which starts with dfabulich-choicescript) on your desktop, in which will be the files for ChoiceScript. The files you will be mainly dealing with are in the “web”, “mygame” and “scenes” folders.


#6

If that’s not the solution, please include as much detail about the problem as you can:

Your operating system and what browser you’re using.
Step by step instructions of what you are doing.
The exact error message, and what program is actually producing the error message. (Screen shots are perfectly fine if you don’t know how to phrase such things.)
Any other details that may be even remotely relevant that you can think of.