Never ending loading bar


#1

I am so sorry if this has already been asked, I have been searching the forums for similar questions for the last hour have found none.

I am creating my own choice of game but when the start up is over and it is supposed to go to the next scene it only shows the loading symbol and doesn’t do anything. Last night I had a similar problem with the start up and divided it into two scenes, it made the first one work but the second one didn’t. So, I have to assume the issue is in the second one. This morning somehow I managed to get it to fully work but then it suddenly stopped again. It isn’t even giving me errors to go by :frowning:

Any suggestions or advice would be lovely! Please and thank you.


#2

Have you tried randomtest? It usually tells you where the error is in your game so that you can go to fix it.


#3

IDE is also a good way to track down the problem. I have had that problem before and it was always some code I messed up.


#4

My number one–maybe only–cause of the neverending loading bar is when I use the same label name twice, if that helps…


#5

For me this happens if the scene file is too long. Over 2.5K words and it loads forever and ever and ever and ever :expressionless:


#6

Thank you all for your responses. I ended up deleting some excess choices and it started working, so, @Carolyne, I don’t know if it was because I did a label twice, or @Aera, if it was because it was too long. But I will definitely try IDE and Randomtest next time, I didn’t even think to try those. :slight_smile:


#7

@Aera
The assassin scene in Trial of the Demon Hunter is 40,000 words and it worked fine :stuck_out_tongue:


#8

I have some very large files and never had it affect the load bar. :stuck_out_tongue:


#9

Then my tablet just hates me @Samuel_H_Young and @Lordirish


#10

@Aera
I have had to work from my tablet from time to time and notice a difference in performance during the build.


#11

I noticed that as well @Lordirish but my three little devil dogs decided to go pee pee at my laptop /:slight_smile: Now it went to laptop heaven O:-) So I’m stuck using my tablet until I buy a new one :-?? Still that must be the reason why it loads forever once I hit 2.5K?