Code issues on dashington's when it works fine with index?


#1

Hi all, wondering if someone can point out if I’m doing something wrong. For some reason my WIP is frozen on chapter two as when it’s meant to go to chapter 3 this comes up and the game ends
goto_scene part3

Oddly enough it works fine when I run it through the “index” file on my computer. This is the coding before the game breaks. (The label’s there as a few different choices converge to that point.) I could try manually putting in the goto_scenes for each choice that goes to that chapter but thought this should work as well?

You wave and head back to your house with a sense of relief.
*goto nextday

*label nextday
*goto_scene part3

Any ideas? Thanks


#2

Are you getting an error message, or does it just freeze?

I don’t know about dashingdon’s hosting, specifically, but are you putting up a compiled game on the site? Or is it running via the index file without having to be compiled first?

I’ve noticed that even though I’m not supposed to have to list all my scene files in startup.txt for them to compile and work properly, I do get an error if I go to any scene not listed. I solved the problem by just listing all the scenes I was using, even the ones I went to with a label instead of via *finish. Then the compiled game worked properly.


#3

Actually you know what, since I upload the files one at a time (not compiled) I’ve forgotten to add the extra chapters to the scene list which I bet is what’s causing the problem. I’ll try that now.


#4

Actually that didn’t fix it either, I was so sure it would :stuck_out_tongue:
What it’s doing is instead of going to chapter 3, it just has the text
goto_scene part3
with the end screen underneath (ie play again etc).
No errors


#5

Did you forget the asterisk?

*goto_scene part3


#6

Nope asterisk is there.
Hmm, maybe it’s just not updating my files at the moment, might need to try again later?


#7

Possibly! Just out of curiosity, have you tried running quicktest and randomtest, just to see what happens?


#8

Yes, they both seem to work fine which is odd. :slight_smile:


#9

That is odd. Sorry I couldn’t help - and good luck sorting out the root of the issue.


#10

No probs, thanks for trying :slight_smile: (I was sure it was that startup file like you suggested. At least thats solved a future problem for me!)


#11

It’s being a bit weird I think. I just tried re-uploading the files and now the main story seems to be running ok but the stats page has an old label and wont update. (Doesn’t affect the story but I can see it doesn’t seem to be updating properly). If I make a new game and upload the same files, it works fine though. shrugs


#12

Maybe you need to refresh your browser cache? Ctrl+F5 on Windows I believe. Might be old files still on your HDD that messes things up. :relaxed:


#13

Well if part 3 is after the other section (I’m assuming part 2?) in the scene list try changing the goto to a *finish and see if that works

Also does the name in the goto match the name of the text file? (Look for capitalization). There cannot be spaces either.


#14

Yeah it was odd, I did actually clear the cookies and it was still playing up. What ended up working was instead of just selecting the files from the folder that automatically opened in the right place, I clicked out of it into a different folder, then went back in and that seemed to upload the correct stats file from there. So might have been some kind of save/remembered save glitch happening.


#15

Thanks Kelvin :slight_smile:
Seem to have it working now. I think the problem seemed to be from an old file that hadn’t been replaced for some reason when I was trying to update it, so was still showing an old one before chapter 3 existed rather than an error in the coding.


#16

Same problem I had last night actually. On Index my game worked fine, but when I uploaded the revised version of my Prologue it showed the old version instead, and I kept trying to re-upload it, clear cookies, use different web browsers, restarted my computer, turned it off and then on. Finally I went to bed and in the morning lo and behold! The game updated. No idea what happened there honestly, but it was with the dashingdon site.


#17

Thanks for letting me know. Was wondering if it was something on my end but seems not then :slight_smile: