HTML file issues


#1

So I’ve compiled an HTML before with firefox, but for some reason it won’t combine all the files this time around? I’ve done multiple quicktests, so there aren’t any errors. My question is could it be the amount of txt. files? Dashingdon accepts 20 at a time, so that’s what I made mine(note this is temp 20, I’m planning on cutting it to four when I start chapter 1). Can compile not work with that much? I’ve done it with 15 so I don’t understand why 5 more would cause an issue. Everything is fine up until the point where it need to combine them and them I get this.

for all eternity and I’m not quite sure why. I’ve even waited an hour and nothing happens. I’m really confused and desperate because I promised I’d have this content out.

Okay so I narrowed it down to 14 and it still isn’t compiling it. I’m very confused.


#2

I’ve compiled games with more than twenty .txt files. Are you sure all your files are in the correct folder, and you don’t have scenes listed in your *scene_list that aren’t in the folder? And the capitalisation all matches properly (not sure if that is an issue, but it might be)?


#3

I can certainly check again. I’m so frustrated, I’m not sure what’s going on.


#4

Are you using the compile.html file in the main folder?

Also, have you tried downloading a fresh copy of ChoiceScript and putting your scene files into that, and then compiling?


#5

No, and that would take too much time. I’m so busy even trying to write a couple of scenes is all i can squeeze in.

I erased all the scenes and added them one by one, not sure whats going on. Ill try checking for errors again.


#6

And you definitely need a compiled version, then? You’d prefer not to host it on Dashingdon just as text files, and let the website do the work of making it playable? That might be quicker, if it’s a viable possibility for you.


#7

True, but I think I might have fixed it. I found a scene i deleted deep within one of the files, so hopefully that works. Thanks for all your suggestions.


#8

At my first attempt compiling CS game, I encountered an exact same error as yours. Infinite compiling.

Try this, change all scenes name into lowercase