Game stuck in loading?

hi!! so pretty new with choicescript and I’m stuck with the loading bar for some reason? i can’t move to the next scene and this happens after i tested the start scene and i don’t really know how to get rid of it? first tried it with the serve.command asset and then i uploaded my game to dashingdon. does anyone have the same problem as i do?

2 Likes

Does the game work when you play it from Dashingdon?

1 Like

nope! i’ve tried it two times, and let it load for about 20 minutes each, and for some reason it didn’t work?

1 Like

Does the scene list you have in the startup file match your actual filenames? And do you have existing files for all of the scenes listed in startup? If you’re getting infinite loading, my guess is the game is searching for a file that it can’t find.

For example, when I uploaded my WIP to DashingDon, my startup file had chapter 3 listed but I hadn’t actually created it yet, so the game infinitely loaded at the end of chapter 2, looking for a ch3 that didn’t exist.

3 Likes

Try sending your files again and make sure there’s no error in your code

1 Like

Screenshot your mygame/scenes folder, and paste the scene list in start up.txt. They should have all the same filenames.

1 Like