Lines Is Not Defined


#1

So I’ll start off by saying I’m not exactly great with coding, so maybe I’m missing an obvious something.

I keep getting the error; Uncaught ReferenceError: lines is not defined from dashingdon.

This happened after I uploaded the second scene and so far I’ve been looking at variables, checking to make sure all my indentation is uniform, et cetera, but no matter what I try it won’t work.

I guess I’ll also add that when I run the game via the Index (using firefox) it just shows as a script error.

Any help is appreciated.


#2

Uh, I’m guessing that means that one of the JS files got messed up at some point. I recommend downloading a fresh version of CS, moving over you scenes folder, and testing to see if that fixes it.


#3

That doesn’t seem to be the problem. I tried that and the same error came up. Everything worked fine until I uploaded that one file so I can’t help but wonder if it’s just something within that text…


#4

Alright, I have no clue what I fixed, but it’s working now.

I put everything I had into ChoicescriptIDE and it, for some reason, was showing a whole bunch of indentations that weren’t showing in my text editor (for some odd reason).

Thanks for your help, though!


#5

Huh.

I assume you’re not using notepad-whatnot, am I right?


#6

Nope, I was using apps called CodeWriter and NotepadX, the former of which has been kind of buggy. I assume that’s where something got messed up.


#7

Oh, I see.
Yeah, I guess that’s the cause :thinking: