How to code accent marks? (á, à, è, ó, etc.)


#1

I have a (new) doubt: how can I make a save feature for my game?

I tried using CJW’s Saving System Plugin, but I noticed I’m not using Notepad++: my own laptop has its own memo pad, which works differently than Notepad++, and I can’t use it with it.

Is CJW’s save system the same as the one used in “From Ashes We Rise”? Or the same in “Zombie Exodus: Safe Heaven” and “Guenevere”?

I don’t want to use the “soft save” system, how can I code the other two?

Edit: I have another doubt… (sorry if I’m annoying…): how can I code my game to display two choices at once? Not like a choice with several options, but actually two of them: like with @Snoe’s first game, “My Imaginary Friend”, or @Reaperoa’s. Solved, thank you! :smile:

Edit: Also, is it possible to use the dash (—) and vowels with accent marks (à, á, è, é, etc…)? When I try to, in the game they look like a black diamond with a ? mark.


#2

I think it should be

*choice
  #Why do you have them?
    "Everyone has them" he answers, shrugging dismissively "even if you don't take Lyssa's drugs, it's like... an unspoken 
    rule".
    *if (insight > 15)
      You have have the feeling there's so much more to it, yet Dagger isn't going to tell you anything more.

      At least for now.
      *goto cast

#3

? Can you bold the difference, please? I don’t see it :disappointed:


#4

*choice
#Why do you have them?
“Everyone has them” he answers, shrugging dismissively “even if you don’t take Lyssa’s drugs, it’s like… an unspoken
rule”.
*if (insight > 15)
ADD SPACES HERE You have have the feeling there’s so much more to it, yet Dagger isn’t going to tell you anything more.

ADD SPACES HERE At least for now.
*goto cast


#5

Oh! They have spaces, but for some reason the code here doesn’t let me put them :disappointed:

No, I have trouble with the second option:

#Why can't you tell me anything more? *if (cqtcm = false) "Dunno. Ask the correct questions to the correct person. I am not." *goto cast *if (cqtcm = true) "Told you already: go and ask the correct questions to the correct person. I am not. Why do you think I know why Lyssa or Furor gave you those?" he snaps as he points the purple bag with his chin, though it's not harshly. *set dagger -5 *goto cast

Line 689: It is illegal to fall out of a *choice statement; you must *goto or *finish before the end of the indented block.

But both of them have goto?


#6

You’re using two *if-statements. Try changing the second one to an else. Otherwise ChoiceScript will not realize that there isn’t any other possible option other than the two you’ve already written down.


#7

Oh! :open_mouth: :open_mouth: :open_mouth:

Thank you very much!


#8

I didn’t see that either, sorry. But when I played the code, it gave me no such error.


#9

Just as a note, though the problem may already be solved-

If you use *fake_choice, you don’t need to provide an *else statement. One or more *if statements become perfectly possible without providing a *goto at the end.


#10

@Just_Because and @Shawn_Patrick_Reed

Thank you very much for the help! :smile:


#11

I’m sorry to bother you, but I have a new query :sweat_smile:


#12

@Grapefruit used a save system based on this for testing Magikiras. It might work for your purpose too. (I do not know exactly how @Grapefruit managed to turn it into a functioning save system though.)


#13

Then I just have to use
*show_password at the end of the chapter and *restore_password at the beginning of the next one? :open_mouth:

Edit: it works!!! Thank you very much! :blush:

Edit 2.0: I can get the lpassword, but how can I get the white box to put it to restore an old game? *restore_password doesn’t work :disappointed:


#14

I don’t know exactly how it works, so it’s just a shot in the dark, but wasn’t the related link in the wiki called *restore_game ?


#15

No, it says it doesn’t have an article about it :disappointed:

When I try to use it the game says the command doesn’t exists, but I don’t understand why: I have seen oher games using that :open_mouth: JimD’s game for example, has it.


#16

Try this step as well.

  1. Open scene.js with your text editor.
  2. Scroll to the bottom and look for Scene.validCommands
  3. Add the following line to it: “restore_password”:1

I feel like there’s another step needed but I can’t remember what it is.


#17

In my game, I had to write my own save system.

Basically, for every variable in the game, I create a second variable starting with a letter like s or x that otherwise has the same name. At the save point, if the player saves, I have it *set svariable1 variable1, *set svariable2 variable2 and so on. Then, when it comes to the load point, if the player loads, *set variable1 svariable1, *set variable2 svariable2 and so on, and also *set all variables between the save point and the load point that are true/false to their default state. Then *go_sub to a *label at the end of the save point. It’s a lot of work, but it actually works (as long as I don’t miss anything and cause bugs).

As to loading- it doesn’t work if the player has finished the game- so the best place to put it is right before the end, in the last scene in your game.


#18

@Shawn_Patrick_Reed What you’re talking about is referred to as a ‘soft’ save system, which means all information is lost after refreshing the browser. It sounds like @Lycoris is looking for a save system that will work even if you refresh/shut down your browser.


#19

That actually brings up a question from me, in that case…

Doesn’t CoG put their own save system into Choice games when they publish the game? I didn’t think there was an option available for hosted games- I mean that, I thought the old password feature had become unusable because of updates to the CS system? I’ve tried working with the password feature and was unable to get it functional for other people- though it would work for myself. Reason for this is because it requires someone to actually mod one of the CS files with a line of code that allows the password system to be recognized. Are you aware of anything more current?


#20

I don’t think there is. I only know of save systems implemented in WiP’s for testing purposes.