Can't get to my next chapter!


#1

I have finished my first chapter but when it transitions to the next all it says is “Startup line 1: Invalid title instruction, only allowed at the top of startup.txt”


#2

It’s saying that the only place where the *title command is allowed is at the top of startup.txt.
Basically you’ve got a title command at the top of your chapter that isn’t supposed to be there.
For titles for chapters people usually just use text in bold or italic, or both


#3

The issue is that it isn’t on the top of my new note pad. That’s why I’m confused it’s only on my startup page


#4

You’ve got a scene list with the name of your next .txt file in it, right?


#5

yup, everything is the same


#6

Strange… Try opening the file in a different version of CS (it might or might not work. I had an issue with the *author command once. It was fixed by downloading the newest version of CS and inserting my .txt files, but I don’t have a clue how)


#7

Where can I find the new CS? (sorry I sound like a noob cuz I am)


#8

I always just use the link from this page. https://www.choiceofgames.com/make-your-own-games/choicescript-intro/
(the one with the word GidHub in it) Don’t know where to get any of the older versions though.


#9

The first lines of your startup file should be something like:

*title [Your Title Here]
*author [Author Name Here]

If it’s not, or your *title or *author command is anywhere that isn’t there, you need to get rid of whatever is there and move those lines to the top of your startup.

If it’s already there, make sure that those commands aren’t anywhere else.

This is where you can find the newest version of CS


#10

Ok, so I have the latest version and my startup file is like that, if I move the line number (by hitting enter) it says the new line number of start up. I think it’s just trying to replay the same one?


#11

The same .txt file? That might be. What method do you use to go to the next .txt file? (like *finish or *goto_scene)


#12

I just used *finish at the end of my startup


#13

Could you post the scene_list (or just the entire code) here? It might give some clues about what’s going on.


#14

write know I’ve only decided on the name of the second part so it’s all good
*scene_list
Startup
Wakeup


#15

Try removing the capital letters (CS is actually case sensitive)


#16

still the same issue


#17

Also, make sure it’s properly indented.

so it should be something like

*scene_list
   startup
   wakeup

Are you getting the same error message you had initially?


#18

it’s the same issue, and they are both 2 spaces indented, I don’t know why it didn’t show up on here


#19

I’m stumped. Well, the error message says line 1, so… What exactly is the first line of your startup?


#20

I’ve been having some weird errors with using *finish (no one can figure out where they’re coming from.) For some reason, I can use *finish at the end of my last scene, but if I try to use it to go to the next scene in my list, everything crashes.

If you are having the same ghost error, I worked around it by replacing every *finish command except the last one with *goto_scene (mynextscene) commands.