[Bug Reports] Treasure Seekers of Lady Luck


#1

Rather than expecting the CoG team and game author to sift through that other thread picking out errors and bugs from opinions and other comments, I thought it’d be a good idea to consolidate all the “technical” issues with the game in a separate thread.

If you’re having any issues and could take a minute to list them below along with any other information that might help identify the cause or location of it (previous choices, screenshots, platform you’re playing on etc), it’d be greatly appreciated.

P.S. Keep your personal thoughts to yourselves for now (or feel free to make a review thread etc), please keep this thread for BUGS only.

Thank you.


#2

@CJW

First, thanks for making this thread, it was a good idea. Now onto my bugs:

I was playing friendly with the GPF officer, and when returning to the ship (second time on planet) after the conversation the captain said “you deserve a promotion but you can’t get one the only higher rank is captain” (not word for word) but checking the stats my rank was “passenger” not even “junior officer” (the highest rank is “senior officer”) (don’t remember my actions)

Taloo is a shy girl who cannot talk but isn’t against murder, and there is actually a scene where she does talk (depending on her friendship level. Shadow home world)

There are many scenes that need to *hide* choices once they are done.

There are missing scenes. E.G the captain never says to put a homing beacon on the GPF detective yet there is a scene where they say “did you put it on him/her” (some people said they got it but not me)

Some choices don’t work even if your specialized in them e.g. “Use force to brake down the wall (tactical)” (this one varies depending on if you speak to your companion first. Once used you can do it again) (not the only one)

When lying to the GFP officer (saying I will help) the game didn’t treat it as a lie. When seeing the captain again it was “I turned down the offer (lie)” or “Actually I took the offer” (again worked for some people but not me)

I killed all the bugs, but at the end of the game, they still came back and helped saying “they thanked me for my peaceful resolution and not hurting them” (or something like that)

A few obvious typos.

This was all copied and pasted from previous posts of mine. If something does not belong (an opinion, etc) feel free to ignore it.


#3

My stats are rather a immense bug could you make that have any sense?:
end stats Mara scientist
expertise: 0
Cowardice 160 but in reality I’m very brave
Follower 115 in reality I’m a leader
Harsh 170 I’m always kind and diplomatic but check options don’t let me use diplomacy

280 loyalty

social
Garce 185 What a hell? I kill him and never give him the reason how could I have 185 with him??

Thisi -30 I try to romance her and in the text says we are good friends but nope…
Kraska 110 I try to be kind with the poor borion but the stats don’t think that way most buggy game I bough ever!! I seek more for a new play

edit: android tablet


#4

@Marajade

I don’t think your stats are bugged the way you think they are.

Cowardice-Bravery is a scale, where Cowardice=0 and Bravery=100. 160 on the coward-bravery scale means that you are extremely brave.

Follower-Leader is another scale, where Follower=0 and Leader=100. 115 means that you’re a really good leader.


#5

well they are really bad explained because I’m totally lost about them. also the lie options with Garce don’t work are consider like I was helping him

also -30 with thisy means? +30 I’m totally lost with this game totally


#6

I noticed that genders would flip randomly through a play through like the captain would be male one moment then say their female, the same for Grace and the “big secret” so I think these gender flags/ markers might be messed up. (I found this through a female play through.)


#7

yeah hi play like a female and found a few of gender changes but I think captain is always a men also who is grace? the captain lover in stasis is a men


#8

@MaraJade
No the captain changes between man and woman as does the one in a coma and the GFP detective. I noticed it to but I thought it was due to my lack of attention after I saw how buggy it was


#9

Yeeah so I assumed a lot of the gender flags or markers were glitched. I thought it was a typo at first but after my 2nd play with the EXACT same cheracter I figured it was a bug since it was more obviouse. Since the lover changed from male to female, and grace changed from a woman to man again.


#10

About the character genders, it is possible that if one or two pronouns always refer to a character as male, whether or not they are, that it’s just a typo. If you notice where exactly these typos are (or any other typos for that matter), just giving us the location will make it easiest to track them down.

That said, all the character have a default gender (that is, in mygame.js all the variables are set to male/female), at the start of the game (before anything else runs), they are randomized. It is possible (particularly if the game is closed then reopened, or if the demo is being played on a spotty internet connection) that the game may ‘forget’ the stat, and they are then reinitialized, meaning they suddenly jump to being male (or it counts them as female, but they suddenly starts using male pronouns). This should be rare, but if you’re constantly looking at it cropping us, giving us every detail you can on what is happening (what seems to cause it, what platform you’re playing on, ect.) may in making this less frequent of a problem.

With that in mind, the more information you can give us in error reports (what happened, what exactly the problem is, the surrounding text, your stats, and anything else you can think of), the easier it is to fix the error. This is always true, both for CoG itself and for any game here.


#11

I’m without a computer until Tuesday.

Please keep sending in bug reports, and I’ll get on them as soon as I get back to civilization.

The genders of the three main NPCs are randomly assigned (Cehnta, Garce, Thela). If you notice a misused pronoun, please make sure to report it.


#12

@WolfieGrey (about your first post)
2) I don’t think it ever actually says that she *can’t* talk, just that she’s extremely shy. (I’d have to go over the game from start to end again to be sure though.)
3) If there a specific choices you think should be hidden once used, can you point them out? Some are intentionally left open for the PC to retread for various reasons.
6) IIRC The captain says something that implies that she doesn’t think you actually plan on doing it if you tell her about it (so, she assumes that you lied when accepting it). Maybe we can add a third option there to help claify?
7) That should not be happening (and I’m failing to see what could cause it in the code). Any more information you can give (about the choices you made) may help in tracking down that error.


#13

@Reaperoa
Just played through and when meeting Taloo, Borion does say “she cannot speak”

  1. I don’t remember the exact path I took (it’s at the end with the "head Northwest/North/Northeast) but I chose the tactical option and killed them when on the Vervoo ship.

I stole the Goblet from the ship, then the wooden bowl, but when I tried to sell them, it would only let me sell the bowl, it said I didn’t have the jewel encrusted goblet anymore.

Some options, regardless of your background (tactical, scientist, stealth) are locked anyway e.g. “Sneaking up on Kraska” and some don’t work straight away e.g. “Searching for a weakness in the wall (Tactical)” only works half the time, and only if I speak to my companion. The same for the Stealth option.

I’m playing on my IPhone.


#14

I killed all the roaches, but at the very end one of them showed up and said they were helping me, I don’t remember exactly why but it implied that I had helped them before


#15

@TDilz
Yes they say something along the lines of “we are grateful that you didn’t kill us” even though we really did.


#16

When first meeting Borion, if you choose to ask him questions without learning his name, the narration addresses him as Borion anyway. It’s not a serious problem but did bother me.


#17

@WolfieGrey You’re right. Do you remember what she said (it’s probably a variable character that can speak up). @TDilz Also do you guys remember what choices you made in relation to the roaches? I’m having trouble finding that error (it may actually have been fixed too, and I don’t have access to the currently released version).

@seryou Thank you, that’s been noted and will be corrected.


#18

@Reaperoa

Like I said, I don’t remember the exact path at the end of the game where you choose to head north, etc. But I can tell you what I did up to that point. I’ll post it soon.

As for what Taloo said, it was in the scene where you arrive on Jeeq, and she says “lets go hunting” or something like it. Thisi says the same thing if shes your companion for that mission.


#19

@WolfieGrey Thank you, that point where she speaks appears to be on the list of things to be fixed (that is, it’ll be fixed in the next update).


#20

I used the lava machine correctly, but Borian was still dead when I got there, apparently because I did some added steps.