Zombie Exodus: Safe Haven -- set for release 10/28/16

#3615

ZE: Safe Haven will be updated at 10pm EST with new content, new NPCs, and new dangers.

18 Likes
#3616

9 Likes
#3617

I feel slightly cheated since it’s already 5:30AM KRAT (May 3) here…

#3618

I love this game as much as I love playing Zombie Exodus and yay for the update later :laughing:

1 Like
#3619

Jim, why was my comment flagged? And thanks for clearing it up

#3620

Forum rules state that you shouldn’t ask when an update, release date, or whatever will be to avoid pressuring authors. Thats presumably why.

1 Like
#3621

YAY 9pm tx time release. Thank god there r some upsides to living in tx

#3622

http://zombieexodus.com/ze2/web/mygame/index.html

15 Likes
#3623

First to be all like OMG update ARGLEBARGLE! Am I doing it right?

2 Likes
#3624

After I go to the convenience store, I have the option to do one of my hobbies. But whenever I choose to play video games, I get to the part where I select a game to play and then a message comes up and says “Line 833 no selectable options.” After that I can’t do anything.

#3625

Not even in the face of Armageddon. Never break kayfabe,

Kelly turns and faces the crowd. “Hey everyone! We have a professional wrestler here now. He’ll make the infected kid come out.”

I don’t imagine this was intended to be as hilarious as it was… Not saying you should remove it necessarily… It’s just… I can’t picture someone saying that with a straight face.

So I’m playing a pro wrestler this run and I somehow ended up with a pistol in my pocket when I had the option to shoot the zombies through the window in Fred’s house. Then when Dante showed up I tried to select different weapons so I could have just my bare hands, but it only gave me the option to select the pistol, and then forced me to use it. Dooming Dante in the process.

1 Like
#3626

Same 833 error as @acham028 after coming home from the convenience store.

2 Likes
#3627

I picked reading as my hobby then went back on it and picked Meditating and Gardening. Now all three are an option in the menu.

On the return from the convenience store I got this as the last sentence on the page.

With the way clear, you stride drive down the avenue toward home.

I was walking at the time.

I got the “strangers” to stick around, but the next morning they went to their car, and then I only had the options to go to the store, try the three hobbies I had unlocked, or change my clothes. I did all of those things, and was left with no other options and got that 833 error.

#3628

I’ve checked twice and I’m still not able to see the new update. Why is that?

#3629

@Imhotep there it is. The update was put out as a comment

#3630

So I have read through it again but it’s the same as before with nothing really changing. What’s the new update supposed to have?

#3631

Dude, that is literally on the first page…

1 Like
#3632

Mine just shows that the most recent update was April 17 and that there were bug fixes

#3633

Did you try to clear your browser history? That sometimes makes problems.

1 Like
#3634

I’m also encountering the issue where no options appear after returning home from the convenience store.