Won't open; says it can't find the file


#1

I click the index file, and Firefox tells me it can’t find the game. Anyone know how to fix this?


#2

Can you provide some more details please.

Where is the index file you’re trying to open located? Is it the web/mygame/index.html file?

Is this your own game that you’re trying to access the index file of?


#3

Yes and yes–it’s the web/mygame/index.html file, and I’m just clicking it to run the test.


#4

Have you tried in a different browser?
Are all of your game text files in the scenes folder?


#5

I can’t get it to open in a different browser without uninstalling and restalling all of them and resetting my defaults. It looks like everything is where it should be; there are no text files outside of the scenes folder, at least.


#6

Hmm that’s odd. You should be able to use any browser you have to browse through your computer files and open it up.

I take it everything’s unzipped?

I’m not sure why Firefox wouldn’t open the file. What’s the exact error message you’re getting?


#7

Everything’s unzipped and ready to go. The error message is "File not found

Firefox can’t find the file at /C:/Users/Monica/AppData/Local/Temp/Temp1_dfabulich-choicescript-dc95e83.zip/dfabulich-choicescript-dc95e83/web/mygame/index.html.

Check the file name for capitalization or other typing errors.
Check to see if the file was moved, renamed or deleted.".

#8

Is it being in the temp folders what’s causing the issue? Do you have it saved elsewhere?


#9

…It’s sitting on my desktop. How would it be in a temp file?


#10

I have attempted to replicate the problem and I think I know what the issue may be.

I believe you are attempting to access the dfabulich-choicescript-dc95e83 folder from inside the .zip archive.

Open the .zip and click + drag the dfabulich-choicescript-dc95e83 folder unto your desktop.
(Or anywhere you’d like to store the folder.)

You should be able to open the index file then.


#11

Your link is saying temp in it. I know that temp files can sometimes cause that error which is why I was asking.

I’d double check that the path to the file is correct.

@Packet That was one of my first thoughts.


#12

That worked! Thank you! XD