The Shore of Two Seas (WIP 75k)

Thanks. I’ll look into it rn. I can see one of the options I wrote is even missing in both cases. Actually, turns out the whole scene is broken. Probably when I changed from space indents to tabs.

  • Should be fixed now
1 Like

Go to your game’s dashboard in dashingdon, and click Edit Details. Check the box next to Use CJW’s smPluginMenuAddon?. There’s a link next to it which tells you the code you need to add to your startup.txt file for this to work.

It’s your choice, of course, but a save function will make it easier for beta testers to look through the different options.

I’m planning to look through your updated version soon, but I’m a little strapped for time now as I’m trying to rush out my files to begin the publication process with HG.

Oh, well that sounds easy enough. I’ll do that right now. Thanks.

  • Done - thanks again, don’t know how I missed that option when I uploaded the demo originally. And congratulations on finishing your project. I’ll give it a try as well once I got some time on my hands.
1 Like

No problem, and no pressure. I missed the option too when I first tried dashingdon out.

I stopped there too, is that the end of the update?

@KoegeKoben that scene mentioned before is still broken got a line 38 error message popping up.

It’s not supposed to be :sweat_smile:

Should be fixed now.

Wow, more and more errors just keep popping up in that scene. Thanks for pointing it out.

I’m pretty sure it’s finally fixed now, I just tested it myself.


Will give it a quick check lol yeah its a weird one considering got a little further the first time demo came out.

@KoegeKoben talking about slaves ran ibto this error

philosopher1 line 137: invalid indent? Expected an #option here, not *fake_choice

Fixed now. Thanks.

Ran into same error for the irony option

I’m fairly certain the entire scene is fixed now, finally. 7-9-13

Will give it another go :grinning:

@KoegeKoben on the playthrough i just finished spotted two things of note code wise 1st is not game breaking but does need cleaned up when the younger confronts the trainer there is a moment where some code shows. 2nd when sparring the younger run into endless loading after beating him. To which i assume is current end of demo.

Other then those two things i enjoyed it and looking forward to seeing more.

1 Like

Found this WiP, and so far really liking it. Really curious to see where this will go.

1 Like

No sure if this is a bug or just the end of the demo, but I’m stuck on the game loading right after our MC spars with the master’s son. Is that the extent of the demo so far, and if not, what’s causing this?

…just sent a bunch of files to hosted games, and trying this over lunch.

It was actually pretty good. I liked it, and have no complaints thus far. Maybe except one…

For the stats screen, you might be able to put Appearance and Possessions, Relationships, Reputation and Personality, on the first page. It is really more convenient to see more things on one stats page - the only time I’d break it up into multiple pages is when the stats screen gets too long. But that’s just me, I’m not sure what the others think.

It is - but it is supposed to go to an ending screen.

Yeah, I’m contemplating what to do, because the way I write/code, I’m tracking a lot of bolean (true/false) variables and using flavour text based on their results, rather than numeric variables and stat charts. These independent flavour snippets are supposed to compound into proper statements about your character, that grow longer and more in-depth the further you are in the story. The idea is that it’ll make for more interesting characterisation than “80% Believer vs. 20% Unbeliever”, etc. I also think it will make it easier to change your character’s personality throughout the game when reaching certain key decisions.

The downside to that is having to balance between having a ton of text on the stat page, or a ton of sub-menus.

I think that you’re right that I’m leaning too heavily into sub-menus at the moment. I’ll try to see if I can find a happy medium for the next update.


Okay, it doesn’t go to an ending screen for me, just hangs endlessly on the loading on bottom right of screen. I’ve tried reloading 3 times from two different saves, still happens. No idea why. IDK if it makes any difference, but I was playing it in Chrome, on PC.

I probably put in *finish rather than *ending now that I think about it. I’ll check tomorrow, about to go to sleep now.

You’re not missing much, except for a “thanks for playing the demo” - so I’ll just say that now: Thanks :heart: