The Midnight Horror -Beta Testing


#1

Beta Testing for a new game by Allen Gies; a free roaming digital adventure set in a lone house out in the wilderness. Expect dread, suspense, and drama. At least, that is what I am trying for.


#2

First up, a link to the drop box index so that people can playtest the game:

https://dl.dropboxusercontent.com/u/89217689/web/mygame/index.html

Second, I know it will need a lot of work, so if there is a typo or error, please include a chunk of text and the scene in which it occurs (Sun-up, Sun-Down, Nightfall, etc) as this will greatly speed my efforts to fix the problem.

Lastly, if you have any thoughts on how to make the game better, or just observations in general, those are always welcome.


#3

vairable18 invalid vairable


#4

I’m not sure what the reason for bumping your Marine Raider thread for a link to this is for, especially since this is still on the first page.


#5

Just a small thing, the nearby town is spelled out as “HollyHock”, shouldn’t that be “Hollyhock” or did you intend it to be “Holly Hock”?


#6

@RagEgnite
It’s not really considered bumping, as Allen was the author of the discussion, and he wasn’t posting something useless like “when is the next update?” Plus, there is a lot more than a page here.

Allen:
Great work on this. The writing is really good as always, and I do find myself a little creeped out by the story. I only got up to the white stones before other things indisposed me, but I do quite like it so far, and I’m excited to see another CS novel by you :slight_smile:


#7

@vampierkid222 - A critical error out of the gate? That isn’t good. Do you recall where it popped up? A sentence fragment would also do as the 18’s I searched for all seem to be correct. Glad to have your input by the way.

@Bloodwyche - Yep. Bad capitalization. Rather obvious now that you point it out. Thanks.

@Samuel_H_Young -I’m glad you like it thus far. I’ll certainly be interested in your opinion of the tone as the story develops. Pacing can be a hard thing to judge and I expect that I won’t get it right the first time, especially in a horror piece.


#8

I always make sure it passes quicktest before posting an update :stuck_out_tongue: just a bit of advice

And I’ll read it all the way through in a few hours and give you some more in depth feedback then!


#9

I found the same error vampierkid222 did after I left the desk in the study


#10

Okay, I gave it another read, though I haven’t read all the way through. One thing I would really like to see are more stats.

Also, here are some typos: “That is especially true when combined with your tire_iron.”
“The timbers reek of long decay, rest piled one atop”


#11

Error: line 18: Invalid variable name: ‘run_goad 0’
Scene: sundown


#12

Error: line 3484: Non-existent variable


#13

@Samuel_H_Young

I still don’t see the reason for it, though.


#14

@RagEgnite it’s like commercials, you don’t want them but they are there :wink:


#15

The opening seemed stuttered. I have options to explore the glove compartment, find a backpack in the backseat, and leave the car. Realistically, there’s no choice, it’s a choice-driven way to show me possible inventory. And then I leave the car.

So at this point, I was like, “this is not the Allen Gies of Marine Raiders or Tin Star. Who is this impostor!”

Then I saw the narrative system at work and thought, “wow, this is unique.”

I would consider one thing though–this could be a realistic 3rd person IF. Maybe make it open with narrative and tell people at the onset how horror movies always play out certain tropes. Give more impetus upfront. It was fun to discover the narrative but it happens fast enough, so it may do better to introduce it first and build it up in the intro.


#16

Hi @AllenGies
I’m excited about your new game and will take a closer look at it to provide feedback. For now I found these for your review. :smiley:

Basement - Chose to hook chain to lower myself down. Got this error: “Line 3484 non existent variable how did i get down the broken stairs”

Examine closet, creating fire in the stove, reading index card about buying more batteries and examine wallpaper all generated this error: “line 18 invalid variable name run goad 0”


#17

@Samuel_H_Young - O, I ran quick-test alright. But apparently I then copied the file from my dropbox to my testing folder instead of the reverse. Ack! Fixing that now.

@vampierkid222 and @that1german -Okay, I found the bad temp value hiding in the sundown file. Haven’t located the line 3484 error yet and it isn’t showing up on Autotest… sigh.

@JimD -That’s a good point. I spent a lot of time trying to be innovative with the arrangement of code and apparently forgot to polish up the beginning prose.

And as you said, at least mentioning the horror tropes and such might be a good way to go because your car is breaking down on the side of a lonely stretch of road. Indeed, I might as well not hide the presence of the backpack and notepad. I mean, you know it is in the car. An option not to take either would be a way to gain narrative points.

Hmm.

@piggleywinks -Glad to have you here. Things aren’t going according to plan, but what fun would it be if they were?

The files are updated, but I’m not certain about the line 3484 error. Working.


#18

Okay, I couldn’t figure out exactly what was wrong with the variable the game couldn’t see even though I certainly could. But since the code worked fine from my personal archive, I copied that over to the drop box and ran it. The error just magically disappeared. Perhaps it had something to do with the very old files I had on dropbox.

Regardless, we’ll use this link from now on.

https://dl.dropboxusercontent.com/u/89217689/dfabulich-choicescript-e14aa48/web/mygame/index.html

As for more stats… would an opposed pair of Cautious/Audacious, Inventive/Wise or Practical/Abstract be interesting? As it stands, the stats are indeed pretty vanilla. I could code in some additional choices and descriptions to reflect those, at least early on when those little things might matter. Later, well, there is a lot of running and terror.

These added stats would also add some initial flavor to be beginning as character choices are made and thus be more in keeping with my previous games’ style.

The archetypes that come to mind for a horror story are the jock, the nerd. the outsider, the ordinary, and the innocent. All of whom would have different reasons for driving out on the lonely stretches, different equipment to start, etc.


#19

With your latest version, no matter what choices I pick, once I click “Next” after getting out of the car, the game freezes and Firefox gives me an “unresponsive script” alert and I have to stop the script (which makes the next page blank except for the title and buttons). Apparently it’s stuck in a loop.


#20

same here