Script Error!


#1

Whenever I try to test my game on Firefox, IE, or anything else, I get a “Script Error” and then it never loads. Could anyone help me with this?


#2

Not without more details no, not really.
It’s referring to javascript, so either you’ve edited one of the js files for a mod and messed something up, or you’ve wrote your variables etc in mygame.js incorrectly.


#3

@ItalionStailon Sounds like a problem with your JavaScript file (happened to me). Check whether your variables have been written correctly, with commas before or after each one, and the : sign between the variable and the value. Also, check the scene part for commas. Ninja’d by CJW, lol. :slight_smile:


#4

I haven’t edited anything in javascript, so I guess it is something in my variables. I’ll look over them again.


#5

YES! I fixed it! After a week, it finally worked! Hell yeah! Thanks everyone. :slight_smile:


#6

@ItalionStailon It’s always a good idea to explain what the problem was (and how you fixed it) - in order to help anyone with a similar problem in the future :slight_smile:

But glad to hear you fixed it.


#7

@CJW Ah. I’ll post what happened then.

In the stats page, I forgot to post a little : after the stat. So this:


stats = {
    leadership: 50
    ,strength: 50
    ,name "Unknown"
    ,sname "Unknown"
    ,gender "Unknown"
    ,hisher "Unknown"
    ,heshe "Unknown"
    ,bloodthirsty "50"
    ,honor "50"

Should be this:


stats = {
    leadership: 50
    ,strength: 50
    ,name: "Unknown"
    ,sname: "Unknown"
    ,gender: "Unknown"
    ,hisher: "Unknown"
    ,heshe: "Unknown"
    ,bloodthirsty: "50"
    ,honor: "50"

Hope that helps. :slight_smile:


#8

Yep, a simple, common and easy mistake to make - still, thanks for sharing that - hopefully people will search and see if they make a similar one :slight_smile:


#9

I can only hope so.