Script Error when playtesting in Firefox


#1

I’ve been trying to get gender variables to work in ChoiceScript, and had some trouble. In the midst of trying out different methods, when I was trying to testplay my game, the dialogue box pops up with a simple “Script Error” message - no specifics about what kind of error it is or anything.

I read that someone else had the same issue, and it had to do with a Firefox add-on, but I don’t have any add-ons so it can’t be the same problem… I’ve tried for hours now getting rid of this message. If anyone know what I could do to fix this, I’d be really grateful!


#2

I don’t know the error but have you tried quicktest and randomtest to see if there are any problems with your code? A crucial mistake might be causing the error? I dont know… I don’t know if this can cause that problem but if you’re using *script command wrong that might be the cause? I have no idea, but try quicktest and randomtest and see what you can come up with :+1:


#3

Thanks for replying!
I did some more testing, and the same error appeared when I used Chrome, IE and Firefox, so I realized it had to be an error with my script, as opposed to one with the browser.
So to try it out, I removed two scenes from the script, and now it works! I still don’t know exactly what I did wrong, but I will be much more attentive to changes in the script from now on :stuck_out_tongue: thanks for trying to help!