Notepad++


#1

I’ve recently downloaded notepad++ but since starting using it I keep getting errors about ‘tabs’ which is a button I’ve never used in the code.

Does anyone know if this is an issue with notepad++ itself?


#2

some times when your typeing code in notepad++ when you hit enter it makes the next line line up with your previous line of code to do this it uses tabs and spaces.
if you goto edit- blank operations you can convert all tabs in the document into spaces.


#3

Thanks @appleduck28


#4

Yeah it auto-tabs, there’s an option to turn it off somewhere.
Settings -> Preferences -> Language Menu/Tab Settings ?


#5

Also, if you want to turn off the auto indent entirely its:
Settings>Preferences>MICS.>Auto-Indent