Next scene fails to load


#1

So, I cannot seem to see what the problem is with this one. Apparently, when you reach this screen, the game freezes (2 of my private testers reported this). I’m sure it is something pretty simple, that will once again show how I can fail to see the obvious in front of me…

faiload

Any ideas?

(code is below…)

With no policemen left facing them, the henchmen look confused. Turning around,
the Steel Aeronaut stops hitting the side of the armoured van, and faces you. "${MC_name}, you never cease to surprise me… "

*choice
#“Well, I realized that I actually like you. Take this as a token gesture of my love”.

    *label aeronaut_love
    *set relationship_Aeronaut %+20
     
    The Steel Aeronaut stays silent for a few seconds, and then returns to hitting the armoured van. A couple of minutes later, it breaks the back door open, and then proceeds to load gold ingots and sacs into a massive container. 
    
    Once finished, the armour turns towards you, 
    opening the cockpit so that you can see the face of the ginger woman you met at the masquerade. "${MC_name}, sadly I've more pressing concerns, 
    and I doubt you'd ever come to visit me in Ghandruk or Khar Khorum. Thus, it's farewell for us".
    
    *set relationship_Aeronaut %+20
    
    *label aeronaut_flies_away_no_fight

    Activating her thrusters, the Steel Aeronaut flies away, while her henchmen get back into their cars and drive off. 
    
    *gosub_scene E_s1_neuron_butterfly_fight
    
    *goto how_to_travel


 #"I just love it when I see you breaking things!"
     
     *goto aeronaut_love
 
 #"Well, I was hoping that if I helped you I might be able to buy you dinner sometime?"
     
     *goto aeronaut_love
     

 #"Look... I never thought I'd find myself in this situation, but I need some money..."
     
    *label aeronaut_gives_money
     
    *set relationship_Aeronaut %+10
     
    The Steel Aeronaut stays silent for a few seconds, and then returns to hitting the armoured van. A couple of minutes later, itr breaks the back door open, and then proceeds to load gold ingots and sacs into a massive container. 
    
    Once finished, the armour turns towards you, and throws you a sac full of bank notes. 
    Then, the cockpit of the armour opens, revealing the ginger woman you met at the masquerade. "${MC_name}, it's the least I can do for your help. 
    If you ever need any more work, come and find me in Ghandruk or Khar Khorum. Farewell!"
    
    *set money +7530
    
    Looking at the sack you realize that there must be several thousand dollars inside it, which could definitively come in handy. 

    *goto aeronaut_flies_away_no_fight

 #"Being good was a bit boring!"
    *set relationship_Aeronaut %+10     
    *goto aeronaut_gives_money

 #"I trust you can open that armoured van. Don't double-cross me, or you'll pay for it"
    *set relationship_Aeronaut %-10 
    *set aggressive %+10
    *goto aeronaut_gives_money

#2

I seriously doubt the save slots have anything to do with it, but have you tried disabling the save plugin to see if the bug reproducible?

If it’s just a paragraph followed by a standard *choice, then I don’t see what the problem would be.


#3

Have you tried moving the scene labels etc below the choice and using gotos instead?


#4

@Carlos.R, I also cant see how this would be the trouble (given that its a very extensive game by now, ~150,000 in code, ~28,000 playthroughs, but if I can’t find any other possible solutions I’ll even try that).

@MeltingPenguins not sure what you mean…


#5

The only other things I can think of off the top of my head are either… the text file uploaded to dashingdon may be corrupt? … or perhaps the text files are saved in inconsistent formats, i.e. they all aren’t in UTF-8?


#6

See if this works:
(Shortened cause im on mobile. Hope itll make sense)

*choice
  #1
    *goto A
  #2
    *goto A
  #3
    *goto B

*label A
Stuff
*goto thing

*label B
Stuff
*goto thing

*label thing
More stuff
*gosub_scene
*goto otherthing

To see if its accidentally looping for some reason


#7

Does it freeze before or after one clicks on an option?


#8

Quick tip: You’re referring to labels inside a choice body. Iirc, CS hates that, unless you used *set implicit_control_flow true


The solution is either you put :point_up_2:t4: that command on your startup, or follow @MeltingPenguins’s suggestion.


#9

Oh, does it? Hm, I use *label inside choice bodies quite often…the only time it’s crashed on me was when I accidentally programmed an infinite loop once, so I try to always put my *goto above the associated *label when possible (loops of course being a time when it is not possible).


#10

Is there any disadvantage to the control flow toggle other than maybe being slightly harder to spot some mistakes in some situations?


#11

You have not included nearly enough to figure out the problem, but in any case, the game hanging like that is indicative that you have an infinite loop in there. Go in and manually follow where it crashes line by line. I’m sure you’ll find something like E_s1_neuron_butterfly_fight ends in *goto aeronaut_flies_away_no_fight or something.

Also yes, CS can be a little finicky about *labels nested in things, but that’s almost certainly not the case here (since it will crash on those). (It actually gets a little worst with implicit_control_flow, due to a minor bug in how that works which means you can’t *goto forward into a nested *label.)


#12

Is it passing quick and random tests (or are you getting longer than expected play through counts?) I had a weird problem that turned out to be an accidental infinite loop I’d created that showed up in the random test when I went through the section line by line a while back.


#13

Thank you all so much for the answers! :slight_smile:

@RETowers, yes, I agree with you… just in this case I can’t see it, but I’ll try some of the other things that people were saying, to try to maybe make it easier to see where the loop is (normally it doesn’t take me long to see it… I worry sometimes about my brain…)

@Jacic, yes, it passes both quick and random tests (and checked that in random test it goes past that part correctly). Makes it all the more puzzling…

I’m sure it is something very stupid… anyway I’ll try to do more step-by-step debbuging tomorrow…


#14

If you’re still having trouble, you could try reuploading your scenes and ask your testers to clear their cache (since it could be storing a previous version). Perhaps you could run the game on dashingdon and quickly click through everything, just to make sure it’s not a problem on your end.


#15

Thanks for all the replies, trying some of these things to see if they work… they strangest thing of all is that everything works fine in my own computer (I can get past this scene… ). Let’s see if the testers are still having trouble…