Log in via Twitter


#1

It’s Andy Why here.

There is a problem with logging in to the forum via Twitter. I haven’t been able to log in for almost a week, despite trying different browsers.

The error report says:
Fatal error: Wrong parameters for Exception([string $exception [, long $code ]]) in /home/dfabulich/choiceofgames.com/forum/plugins/Twitter/class.twitter.plugin.php on line 302

Can anyone explain/fix this?


#2

It’s been over a week now and I still can’t log in. Any ideas? @Jasonstevanhill


#3

If I recall correctly, the author of the upcoming game “Slammed!” has also has this problem- maybe try asking @dfabulich as it seems to mention his name on the error report, and I’m guessing he’s more than competent when it comes to stuff like this- after all, he did invent ChoiceScript!

If the worst comes to the worst, I suppose using a new account may be the only option- however, I’m sure that this will be fixed soon!


#4

Yeah, it may be a while. Dan just doesn’t have time to fix it right now.


#5

It’s because of a recent change to Twitter’s API.
There’s a temporary solution in the form of referencing an old version, outlined here:


#6

I’ve implemented the temporary solution; logging in with Twitter seems to work now.


#7

I believe there are problems with twitter again… I tried logging in from work and it wanted a forum username and password (which I don’t have). I also tried from my phone and it said the same. Luckily, I’m still logged in on my home PC (where I’m writing from), but as soon as I log out, I won’t be able to log in again… Any suggestions?


#8

I doubt there’s anything you can do on your end @andymwhy
It’ll be down to Twitter and Vanilla.


#9

Does anyone have any idea how long this is likely to take to fix? I haven’t been able to log in for 2 weeks now :frowning:


#10

It’s probably been caused by yet another change in Twitter’s API, I would imagine it’ll require administrator attention to fix. On a possibly related note the Google login has been playing up for me every now and again, I’ve got (but don’t always get) an error message, something like a “unique id required”.
Funny thing is, if I’m already logged into Google, then log into the forums (as opposed to logging straight into the forums), it’ll tend to work no problem.


#11

@CJW I get the same thing on my laptop but not on my phone.


#12

Ack I jinksed myself. Now I can’t log in with google on my phone. :frowning:


#13

@CJW I tried that with twitter. Starting from logged in (as normal) and logging out then trying to log in. No luck though. Through twitter it asks the same as google: unique ID required.


#14

I’m glad in log in with Facebook, I’ve never had an issue logging in.


#15

I log in with an actual password and my username :stuck_out_tongue: it seems to be safer, even though we were advised to use a social network.


#16

I dont have social networks :3


#17

Google is getting worse, I’m having to try to log in 3 or 4 times before it works :confused:


#18

@jasonstevanhill @dfabulich
This issue is getting increasingly problematic for me, it’s often taking me up to ten or twenty attempts to sign in (with google) without getting this error message:
http://gyazo.com/07caed66a707f97f0e8a176f073285ae

Topic with possible solution(?) here, best I can find: http://vanillaforums.org/discussion/comment/201497#Comment_201497

EDIT: I’ve actually managed to work around this by asking for a password reset, so I can now login like a normal user - but it’s still something that I feel needs sorting.


#19

@CJW lol I have given up altogether loging in with google I do hope it is fixed soon makes login far simpler for me.


#20

I think I fixed login with Twitter. (Again.)