Linux Issues on Steam

I decided to quickly mess around with Night Road to see if I could replicate the issue, but I cannot, and given I would not know what the thing is checking for (to see if it is purchased), I would not know what to look for.

I can only make three suggestions at this time.

  1. I think the lag is normal when using Proton Experimental. I just tested it, and I have the same issue, but it corrects itself if using Proton 4.11-13 (when not using any Launch Options; using any might break it). If you must use Proton, I would see if that works better for you.

  2. Were you originally running the games through default (non-forced), or forcing the Linux Runtime? The latter does not seem to work correctly, so try the other if that is the case.

  3. Try disabling Steam Cloud Saves if they are enabled (so it does not undo the next step), delete the local saves (back them up first), and see if it is in some way related to the save files. Since it seems all of your saves would have needed to be affected… and I think they are shared with the Windows version, I doubt the issue is related to the saves/configuration folder. But, well, process of elimination.

The folder should be located in Steam/userdata (then your Steam number), in the folder 1290270 .

Alright… I tried 4.11-13 again and it says it cannot connect to Steam, and tried Experimental again and it played the game smoothly. So 50/50 on it working better than Experimental. I have no idea what changed between tests. Also, Experimental looks like it may have been updated to not require the old launcher settings I had to use before, so if you are using them, removing them might help. shrugs

Previously to all of this I had simply been running my games with the default settings, using no compatibility tools and no command line/launch options.

Since you made me think of it though, I just gave the Linux Runtime a try and it resulted in the game just failing to start. No window pop up or anything. It was just ‘Running’ according to my steam library for a moment and then it stopped.

Proton 4.11-13 just gave me the ‘There was an error connecting to Steam’ message.

Steam cloud saves were already disabled for all of my CoG games, but I deleted my saves and tried that with no change in the result.

Thanks for the ideas to try out.

Hmm… alright.

My only other idea, at this time, is I was able to get the forcing Linux Runtime option working by using a workaround, which is the only other thing I can think of to change.

For reasons I do not understand, the Linux Runtime running by default and forcing Linux Runtime appear to work very differently (I have never heard of a game differing between the two before the Choice games).

Forcing the Linux Runtime under Compatibility works for me under one condition: rather than clicking Play, instead go to Local Files and run the executable directly (while Steam is still running, otherwise it will error out).

Does that result in the same Demo-only problem, or does it behave differently?

I don’t think I completely follow the workaround you’re suggesting. I’m fairly new to Linux and unsure of how I run an executable directly, or even 100% sure which file it is. In each of my CoG game folders there’s a file with the name of the game and no extension which I guess is the .exe file, but my system doesn’t recognize it/know what to do with it (and neither do I).

If this involves Wine, I haven’t actually used it yet. Most of the games I play work fine on Linux natively and the handful that don’t I have on Steam, where I just find a the right version of Proton and/or launch option for them. So I don’t actually have a general Wine program installed. If that’s what I need to do next to try this workaround, I’m just going add it to a to-do list for now as I’m just low on mental energy at the moment.

To step back, I’m not really anticipating or even needing to find a solution here. As I can still play my games via Proton (even if it’s laggy) and haven’t been in the mood to play any of them at the moment anyway, I really just wanted to make sure this new bug with the last round of Linux updates was reported somewhere CoG devs would see it.

And if it’s really just me experiencing this, I wonder if it’s something specific about Mint 19.3 that doesn’t play well with the change to the CoG engine. If it is, the problem might effectively solve itself by around April of next year, which is when Mint 19.3 reaches the end of it’s life and those still using it will (presumably) upgrade. I’ll have to do that myself at some point soon and, if nothing else has by then, I’ll find out if that fixes it. Thanks for your help, Noiram.

Ah, okay then.

Also, just for future reference, the below is what I was suggesting. No need to read it if you have no use for it, it is just there if you (or anyone else) has a use for it. It does not involve WINE, and should not require installing anything but the game itself.

Note: the below should work, but may not if Steam was installed as a flatpak (which restricts access to the system).

  1. Enter Night Road’s Properties.
  2. Force Compatibility to Steam Linux Runtime

At this point, clicking Play seems to not work, so…

  1. Go to the game’s Properties, then Local Files, then Browse.
  2. Execute the file NightRoad.

You can do this with the visual interface, but as that can differ depending on your desktop environment, I will simply state how to run it using the terminal.

In the terminal, typing “./NightRoad” (without quotes) will launch it.

I just tried pushing a new build of Night Road that might help.

The app is designed to start up and query to see what you’ve purchased, but if it can’t connect to Steam, then it’ll falsely think you’ve purchased nothing (which means you’re in the demo). Steam recommends calling SteamAPI_RestartAppIfNecessary to restart the app if it can’t connect to Steam, but in the Electron update I posted about upthread a couple weeks ago, I didn’t call it. Now, Night Road does call SteamAPI_RestartAppIfNecessary, so I’m hoping that fixes your problem.

After the update every game runs smoothly natively and the issue seemed fixed. However, yesterday I was not able to launch the latest hosted game, “The Passenger”.
I’ve tried the usual stuff (uninstall, reinstall, check files integrity etc) and I even tried running it with Proton (newever and older versions alike), but I was not able to launch it.

To be more precise, if I try to launch it natively nothing happens, while if I try with Proton a blank screen appears with an error message (it mentions error code 77779).
I’m using Ubuntu 20.04, if that can help.

Am I the only one experiencing this? Was someone else able to run it on Linux?

I have the same error as you. Have you managed to fix the problem since your message?

I contacted the support team and they told me the problem was on their end. I can confirm you they fixed that issue and now every game that had problems runs smoothly (just checked on The Fernweh saga, The Passeger and Fallen Hero 2 - those were the games I own that didn’t work).

Be sure you’re not forcing the compability with Proton, because now the games run natively on Linux and with Proton they don’t launch.
A month ago I also had to reinstall Steam (through Flatpak), so I don’t know if that helped someway with their update. If someone also can confirm everything is working I’d be grateful.

Anyway, if you’re still having this issue you can try to play the games on a web browser. Just be sure to let CoG website store cookies and to not play on anonymous window.
Games’ progess is stored locally, so if you wipe out the cookies/don’t allow their storage every time you play you start from the beginning and can’t save your progress in-game.

Hope that will help improve your experience!

1 Like

Thank you so much for all this informations! ^^

1 Like

Part of the mass update of Linux builds I just did was an attempt to improve compatibility with Steam Deck.

Valve has a Steam Deck Compatibility testing team. From time to time, they test out our games on Steam Deck, check for compatibility, and post results. Prior to the most recent round of updates, they would normally say that our games are “Unsupported :no_entry_sign:” on Steam Deck, but, on the current version, they typically claim that our games are “Verified :white_check_mark:

But, to my surprise, they claim that the native Linux version didn’t work on Steam Deck, so instead, they were testing our Windows build via Proton. That does work if you use the latest version of Proton, but it just doesn’t work as well IMO as the native Linux version.

The reason they were using our Windows build on Proton instead of the native build is that they only want to test the native build in the Steam Linux Runtime. (You can test the Steam Linux Runtime yourself by using the “force compatibility tool” feature in your Steam Library and selecting “Steam Linux Runtime” off the list. It’s wayyyy at the bottom, under all those Proton versions.)

Last week, I discovered that all of our apps (all apps built on Electron) don’t work in the Steam Linux Runtime. I filed a bug about this here:

I was pleasantly surprised at how helpful the Valve team was at helping me diagnose and fix this issue! They have a fix forthcoming in a beta version of the Steam Linux Runtime. I just tested it myself with Steam Linux Runtime on my Steam Deck, and it works great, better than Proton.

… but the Valve developer “smcv” who has been working with me on this issue said something a bit ominous as well.

While testing this more thoroughly in preparation for a new beta, I found that on a Debian 11 host system with AMD GPU and Mesa, the Slammed and Heart of the House demos running under SLR both crash shortly after startup (I get a white window for a moment, but no text is drawn) with a segfault in the Chrome_InProcGp thread. The sniper runtime behaves similarly, and so does the non-container scout runtime.

Debian 10 and 12 on the same hardware are OK, and so are Arch Linux, Steam Deck, and Ubuntu 22.04 on different hardware. (It could be a graphics driver bug specific to the version of Mesa in Debian 11, I can’t tell.)

This isn’t a regression, and your games don’t run under SLR by default on anything except Steam Deck, so I’m treating this as non-critical and will proceed anyway; but I thought you should be aware that adding these few libraries is not a 100% solution to running Electron/NW.js games in a cross-platform way.

I verified that our games work great in the Steam Linux Runtime on my Steam Deck, but I don’t have a wide variety of Linux versions to test. (I’ve lent my Intel machine to a friend, so currently my only Intel Linux box is a Steam Deck.)

Therefore! I’d appreciate it if y’all would try out our games in Steam Linux Runtime on whatever version of Linux you happen to run, and let me know how it goes.

Here’s how!

Please test our games in the beta version of the Steam Linux Runtime

  1. Go to your Steam Library. (If you’re testing on Steam Deck, you’ll need to switch into Desktop Mode to do this testing.)

  2. In the upper left corner, there’s a dropdown, “Games.” If you click it, you’ll see that, by default, Steam Library shows Games and not Tools. Check the box for “Tools”.


  3. Once you’ve enabled “Tools,” you’ll see “Steam Linux Runtime” and “Steam Linux Runtime - Soldier” in your Library. Click on the “Soldier” version.

  4. In “Steam Linux Runtime - Soldier,” click on the gear icon to “Manage” and then click on “Properties…”

  5. Click on “Betas” and select “client_beta”. Close the Properties window. (It may take a minute to download the beta.)

  6. Download one of our games (or a demo, if you prefer), select it in Steam Library, and view its Properties, like you did for Soldier. I’ve mostly been testing with Slammed, but I believe any game will work.

  7. Click on “Compatibility”, check “Force the use of a specific Steam Play compatibility tool”, and select “Steam Linux Runtime” from the list of tools. (It’s wayyyy at the bottom, under all those Proton versions.) Close the Properties window.

  8. Try playing the game. If you can launch the game and click around for a few screens, that’s all I need.

  9. When you’re done, you probably want to opt-out of the Soldier beta. Go back to the “Betas” page for Soldier and select “None.” (Slammed does crash on startup when opting into the non-beta Soldier SLR; that’s expected.)

I’ve been testing on Steam Deck, and it’s working great on the Soldier beta, but it might not work on your machine, and, if not, I wanna know.

In particular, the Valve developer “smcv” reported that Slammed just crashed outright on Debian 11 (but worked fine on Debian 10 and Debian 12). Does it crash for you on the Soldier beta?

I’ve tried to test Royal Affaris, Werewolves Haven Rising and Fallen Hero Rebirth with the beta version of the Steam linux runtime but unfortunately the games didn’t launch.
Please note that I’ve installed Steam on Ubuntu 20.04 through flatpak and some compatibility tools don’t work (to be precise the newer versions of proton, 5-6-7, installed alongside the Steam client, but on the other hand the older versions and the community built ones installed with flatpak work flawlessly). So maybe it has something to do with the flatpak installation.

Messing around a bit I tried launching the games with steam tinker launch and forced the steam linux runtime from there and then the game started. Unfortunately the mouse didn’t work in-game but with the keyboard shortcuts I was able to play without issues.