Can't play choice games anymore

Hey Community!

At least since I installed my second GPU, I’ve been unable to play any CoG or HG title from Steam.
The game will start up, basically as normal, but instead of displaying the expected first screen, it’ll just be completely white.

All the graphical and text elements are still there, which I know because I can grab the logo in War for the West, e.g., and drag it along with the cursor, but when i let go, it instantly disappears again.

My Steam library contains practically every game released by CoG and HG on that platform, so I’ve obviously not tried all of them, but among the ones I did attempt to play were the most recent ones, Breach and War for the West, Drag Star!, Blood Money, as well as some older titles like Choice of Broadsides.

I’ve emailed support about this, but I figure someone on the forum might have had a similar problem before, so might as well ask here as well.

My system is as follows:

Win10 64bit
2x GTX 1080ti
Desktop res 4k@10bpc colour depth

Running all latest drivers and windows updates.

Things I’ve tried so far:
Disabling SLI
Verifying file integrity
Windowed mode/Fullscreen

I really hope someone on here can help my out with this.


PS: Here’s what that looks like in Sword of the Slayer, which incidentally is the last release I successfully played:

Have you tried changing the resolution down to 1440 or even 1080?


First, thanks for the quick response.
I didn’t try lowering the res, but I did resolve it another way.
For some reason, setting the .exe to run in admin mode made everything work as normal, bar having to confirm that I would like to allow the app to make changes every time I want to play a game.

So thanks again.