Invalid character?


#1

I tried adding another scene by editing the mygame.js file and creating the text file in the scenes folder but got a “permision denied” error. I read somewhere that unblocking the files would solve the problem, but when I did this, I got an “invalid character” error, and when I try to start the game, it says that I need to enable javascript. I know javascript is enabled because before the game worked fine. What should I do? Thanks in advance.


#2

@haqeirah At a wild guess, I would have to say it’s possibly not been unblocked properly, as “Invalid Character” seems to be the typical error for that:

I think in this case I would be tempted to move my own .txt files safely elsewhere, zap ChoiceScript entirely, and go with a fresh download / unblocking before putting my own .txt files back in place. If you already have lots of variables set up in mygame.js, copy & paste those to a text file first (for pasting back in afterwards)–i.e. don’t be tempted to use the same copy of mygame.js. A completely fresh install sounds like the best way to go, just to be on the safe side.


#3

I’ve discovered that it’s only the scenes that are effected. I tried unblocking it a few times but get the same problem each time. But if I don’t unblock it, everything works except I can’t add new scenes.

I’m posting my mygame.js file in case anyone can spot any problems with it:

// Specify the list of scenes here, separated by commas, with no final comma

nav = new SceneNavigator([
“startup”
,“animal”
,“variables”
,“gosub”
,“ending”
,“death”
,“test”

]);

// Specify the default starting stats here

stats = {
gotolabel: “”
,testing: true
,bonded: false
,dname: “unnamed”
,empathy: 0
,dtrmnd: 0
,humour: 0
,honour: 0
,honesty: 0
,eyecolour: “unknown”
,scep: 0
,leadership: 50
,strength: 50
};

// Specify the stats to use in debug mode

// debugStats = {
// leadership: 50
// ,strength: 50
// };

// or just use defaults
debugStats = stats

Thanks.


#4

I’ve solved the invalid character problem but it won’t load the game if the files are unblocked because it says I need to enable javascript. It works ok if I leave the files blocked, but like I said before, I can’t add new scenes. Any ideas about what’s wrong?