How to use contractions?


#1

Hey, how do I use contractions in the coding? Such as “They’re” or “won’t”. They show up with a “?” in place of where the contraction should be.


#2

@NothingAiden
Don’t. Just write it out completely.
For as far as I am aware those signs are just not supported by ChoiceScript.
Just like é ó í ï ed.


#3

I use to have it becoming ‘?’ when I write it in Microsoft Word and paste it in the coding.
I guessed that’s happened because the format is different. If you write it in the code from the beginning, it won’t come out that way.


#4

Thanks Cooncat, fixed it.


#5

Microsoft Word puts “smart quotes” in. So, if you look at the ones I just typed, they’re straight up and down, but the ones in Word are little curly “tadpoles” and the one at the front looks different than the one at the back. When you copy smart quotes from Word into a text document used for coding, you’ll probably end up with problems, at least when viewing the final product in a browser. You can shut off the smart quotes option in Word. You may still have problems with other characters it puts in, like a long hyphen, etc. You can shut those options off, too.


#6

MS Word does that with quite a few auto-format things - that’s why we generally recommend using Notepad or Notepad++ (a free download) to write your code.:slight_smile:


#7

I had the same issue, you have to use the notepad text editor, coz the MSword characters will show up as “?” even though they look the same. I just use replace all and change all notations into notepad format.