[Solved] - Problem with Quicktest and *set - IT WAS REALLY SMART QUOTES


#1

Hey all,

I was having an issue with Quicktest where I would get an error "Invalid expression: couldn’t extract token “string_variable” " after a *fake_choice or *choice #option and trying to *set a string variable. I was using a format of two-space indents, as I have a small screen on my laptop and prefer to do it that way. All of my code was hunky-dory using the two-space indent method until this. Once I replaced everything with four-space indents this issue went away. Nope turns out it’s not working. Not sure why quicktest didn’t catch it that one time. SO still need help please!

Here’s my code:

I’ve also tried it this way:

Also, found this on the wiki: Invalid expression, couldn’t extract another token
If this error occurs, it means you’ve used characters that don’t exist in the english language. Note that most programming languages require you to only use alphanumeric characters that exist in the english language (which means if you use the “alpha” character from the greek alphabet, you’ll encounter this error).

But “City Streets” is all english alphabet? :confused:

UPDATE: I got it! I had copied and pasted from MS Word because I was spellchecking stuff. The quote marks weren’t native to the coding language. I have to manually type them in Notepad++

-Ariella


#2

Those look like curly quotes (aka ‘smart quotes’). Did you write that in Word first?


#3

Yes I just figured that out lol. Goddamit I wish Notepad++ had spellcheck. I usually copy + paste into word to spellcheck.


#4

If you dig around in the extensions for Notepad++, you should be able to find one (it’s a pain to get working though IIRC).


#5

I had tried but apparently the spellchecker is bugged with the most recent version of Notepad++ and now I have run out of steam lol. Maybe if I get an older version of Notepad++ it will work. For now I’ll just have to remember to change the quotes manually when I spellcheck


#6

AHA. AHA. I CAN DISABLE SMART QUOTES IN WORD. HUZZAH. YAY.


#7

There are two popular spellcheckers for Notepad ++ … the built in spellchecker seems to be working with the newest version… you just need to enable it. (I googled it) and update the dictionary itself if desired.


#8

Do you have a link by chance? I also googled it but that’s how I got the non-functioning one :confused: