Need help: Invalid expression, couldn't extract another token


#1

Hello, I need help with an error that I can’t make sense off. Here:

The concerned bit of code is this:

*choice
 *if (theatricality > 50) #...
  ...
  *choice
   # 
   #

I already solved a similar error earlier, but the problem does not seem to be the same at all. And there seem to be nothing wrong at all with this particular part the error is indicating. I’ve tried looking higher and lower into the code, but nothing seems to be wrong.


#2

I forget, doesn’t the red disk icon in notepad++ mean that a file isn’t saved?


#3

I just had this error but with a nested *fake_choice within the choice, the only way I could fix it was not nesting it. You could try moving the nested choice to an entirely new label, I think that’ll fix the issue.


#4

Well, quicktest and randomtest willl always report error whenever they pass through a nested *fake_choice. But the truth is, you can play through it in-game normally (not on every occassion, ofc).

That’s one of the reason why I rely on local Alpha-Testing rather using quicktest/randomtest :frowning_face:


I’d agree with @RETowers at here. Maybe you forgot to save your changes, @bl00dragon :stuck_out_tongue_closed_eyes:


#5

Really, I had no clue! I still feel like I need to appease the technology before I put out content for human testing. :stuck_out_tongue:

I actually thought the red text is the usual color of choices with the syntax highlighter.


#6

Lel. What I meant by local Alpha-Testing is actually “I’ll skip-read and click my mouse rapidly on all of these possible choices on my laptop” :laughing:

About the red coloration, it’s actually the OP’s preference.
And I don’t use red. It’s evil :roll_eyes:

:running_man:t5: :fog:


#7

@Szaal :woman_shrugging: I use Sublime now, and I have a personally written syntax highlighter. I like having the ability to arbitrarily highlight whatever I want in whatever way I want.

@seabean However, that’s not what I’m talking about. In the screenshot of Notepad++ there are a bunch of tabs at the top, each with a floppy disc next to it. I believe the red floppy means the file is not saved.


#8

Yeah, because I changed something before the screenshot.

Choice within choices don’t work? Ok then.

Nope, that’s not it. XD

That’s my personalized version of the highlighter.

Yep. I use it because it’s very noticeable. But I understand that it would hurt other people’s eyes. :3

Yes. But I reflexively save every time before I test it.


#9

Ah, btw I just remembered!

Try moving your #Option away from the *if

I mean, from being this :x:

*choice
 *if (theatricality > 50) #...   <<<
  ...
  *choice
   # 
   #

To this :ballot_box_with_check:

*choice
 *if (theatricality > 50)
   #...   <<<
   ...
   *choice
    # 
    #

Surely the following related indentation should be bumped once more :thinking:


#10

Ok, I’ll try doing that.


#11

It works now. Thank you.

While I’m at it, is there any way to stop the annoying bugs that happen when you do not launch the game in a private window?


#12

Private window? Do you mean something like anonymous browsing ?:bust_in_silhouette:


#13

Yes. There’s bugs that appear randomly, often with indent, when you don’t open the game in a private window of your browser.


#14

Hmm… I just did a quick local testing via private window and didn’t catch up any bugs.

What does the error report said when it shows up?


#15

The errors only appear when you’re not in a private window. It’s linked to Dashingdon I think.

Just a regular indent error: “is 2 should be 1” when the indent is perfectly fine in the code.


#16

Oooh
So you’re testing your WIP on dashingdon while not in a private window, then?

I’m not sure if it’s the case, but try the old trick of clearing your cache/cookie/whatnot