Goto_scene errors, and other things

Hello again. I was going to use the previous thread, but forgot they had a time limit.
So, I figured out how to get between scenes, although unfortunitly now it’s saying that it can’t find the file in the scene’s folder. Tried a few things, altering the scene_list in startup, altering the titles of the individual scenes. Not quite sure what’s going on.
Also, still running into the problem of haveing only the 1 choice, although I replaced the *finish commands with mostly *goto_scene, since I suspect this will be mostly how I set up choices, if I can do that.
Any ideas on why the scene file does not seem to be showing up? I checked the spelling, and yes, they are spelled the same, so it should not be that.

Case sensitivity. Make sure not only the spelling, but also the capitalization (and also the .txt extension while at that). Oh, and are the scene files in the same folder as the startup.txt?

Capitalization is correct, made sure of that.
It’s a text document, so I assume it would have the.txt extension.
Also, yes, all the scene files are in the same folder as start up.txt.

Then what about the *scene_list. When you list the file, just put in the filename without the extension.


So, I ended up fixing the problem. It seems that I forgot that I capitalized all the stuff in my seen underline list section. Silly me :slight_smile:
Now I just have to figure out why it keeps asking me for a choice body. If I try indenting and it thinks it’s an option and wants the number next to it, if I just leave it and bring the go to underline seen command up it’s still wants a choice body. I am looking in the choice section of the wiki, but it does not seem to be giving me anything at the current time.

1 Like

If you aren’t already, I highly recommend you use CSIDE to write your story/game. The error console does a really good job of showing you exactly where a problem is (including things like indentation/spacing errors).

I did download that, but I haven’t really gotten around to looking into it too deeply. I have done a bit of that now, though I’m a little unsure as to how to actually get it up and running. I looked at the Documentation that you get when you open one of the folders and it sends you to a page, but it didn’t really say much about how to actually get it set up, and what files to open.
I am assuming it’s a file called node in the main directory, but when I try to open it it doesn’t seem to do anything. Just hoping it’s not a pop-up, I’ve never been particularly good with those. For whatever reason my computer doesn’t take them particularly well.

If you’re using CSIDE you shouldn’t have to mess around with node (or even download ChoiceScript), it’s all contained within the app for you. Just load it up and click the ‘+’ button at the top left to create a new project.

I was just looking through the original "startup file I was given with the choicescript, and I am a little confused.
*finish is used to end a scene, as far as I know.
So, I am a bit confused when I am reading the Startup.txt file from the Dfabulich folder that I got, I kept a coppy as a templit, and seeing all the *finishes, even though you can choose 3 choices.
Does this look right? If not, why. If so, please explain? I am confused.

  #Make pre-emptive war on the western lands.
    If you can seize their territory, your kingdom will flourish.  But your army's
    morale is low and the kingdom's armory is empty.  How will you win the war?
      #Drive the peasants like slaves; if we work hard enough, we'll win.
        Unfortunately, morale doesn't work like that.  Your army soon turns against you
        and the kingdom falls to the western barbarians.
      #Appoint charismatic knights and give them land, peasants, and resources.
        Your majesty's people are eminently resourceful.  Your knights win the day,
        but take care: they may soon demand a convention of parliament.
      #Steal food and weapons from the enemy in the dead of night.
        A cunning plan.  Soon your army is a match for the westerners; they choose
        not to invade for now, but how long can your majesty postpone the inevitable?

end of code.
I didn’t put the =( and ) in my script, that was just an atempt to bookend the code, for easier reading.
I tried doing that with my script, although I suspect I messed the indentation a bit, but that’s unrelated currently.
However, it still only came up to let me do the first choice. I put 3 different choices down, all formated like that. Again, I suspect indentation was off, but again, that’s not important for the current discussion, since it will give me indentation arrors.
Anyway, I am confused. That file, the Dfabulich original Startup is not makeing sense with the infermation I have gotten from the Wiki, and experience both here, and when bug-testing my script.
If someone would please assist me with this, that would be highley apreteated.

That part of the code is right as it is because the next part of the Fabulich example is completely unrelated to this choice and starts up a new scene_file.
If your test really only showed the first choice it’s most likely the indention that’s got messed up as you thought.

There is a really neat beginners guide that might help you get a better overview on using Choicescript and coding with it

1 Like

Thank you for the link to the Choice script guide, from what I have seen while looking over it it seems to be a lot more informative than the wiki.
In regards to the choice script ID program, does anyone happen to know where a good resource to actually getting it all set up and such is? I found the resources that are in the directory itself on how to use it and such, but currently I can’t seem to open it, I am assuming that the file called node, with the extension DLL is what you’re supposed to open, although I could be incorrect.
As it stands now, when I attempted to open the note file, aside from asking me once what I wanted to open it with, which I think I got sorted, now it’s just not doing anything.
In fairness though, it might be generating a pop-up that I just can’t see.
Also, partially if this particular program doesn’t work for some reason, and partially just in general interest, does anyone know how to alter the number of spaces that each tab will do in the windows notepad?
Have not been able to find any resources on how to do that, however I apparently found resources to do pretty much everything else in notepad.

This topic was automatically closed 24 hours after the last reply. New replies are no longer allowed.