Finish command not working in choice

Hey, i’m trying to understand how Choicescript work before making a game and while everything I’ve done worked before, it seems like *finish command decided not to work for me.

My startup file has some text with

in it, no problems on this file but then I moved to another file with goto_scene cheese(wanted to test choice don’t laugh too much) at the end.

Code looks like this:

Do you like cheese ?
 #No, I don't.
  Meh, you'll never fit in France.
  *finish Meh
 #Of course, I do!
  France has more than 1200 varieties of cheese.
  *finish Nom nom

Game only show me “play again” screen instead of going to continue file which only has one line of text in it or putting an “meh/nom nom” button (added those cause it didn’t work with just finish so I’ve thought it would maybe work with text next to it)

Thanks in advance.

Do you have cheese in your scene list? If you don’t have it listed, or it’s listed as the last file, using *finish will mean ending the game.

I recommend using *goto_scene continue instead of *finish if you want the game to go to that file.

Worked, i didn’t think it would need to be in it too but at least I’ve learned something new, thanks you.

1 Like