[CSIDE] The ChoiceScript IDE (v1.3.3 Now Available — 05/09/2022)

first of all I’m so ashamed I have to post something like this, but it happened overnight and now I don’t know what to do


This morning my CSIDE shortcut turned to this, I used CSIDE for years and this is the first time I got this, tried to uninstall - and - reinstall but the shortcut always like this no matter how many times I reinstall.

And this is the inside of CSIDE folder:

is there any missing file? please help, thank you

It looks the main application binary (ChoiceScript IDE.exe) is missing. My best guess is that an antivirus software package has quarantined it? That’s the only explanation I can think of that would not be fixed by a reinstall.

I’ve just spent my entire morning working on fixing my laptop after I woke up to a looping blue screen of death – so unfortunately I had to completely wipe it for a factory reset.

Thankfully, I had a lot of my documents saved onto a flash drive so I didn’t lose too much. Unfortunately, I’ve run into some issues while trying to re-download CSIDE. After downloading and opening it, the following displays:

I’ve tried deleting all files and redownloading, but that hasn’t helped. The only way for me to close out of this tab is through Task Manager, as it’s otherwise unresponsive.

Thanks in advance for any help!

Try updating CSIDE manually.

Download this file (v1.3.3):

Then rename it ‘package.nw’. Note the extension must change; make sure it hasn’t been renamed ‘package.nw.zip’. Then replace the file with the same name in the CSIDE installation directory.


Hi all, just cross posting here. I’ve been having some compiling issues with CSIDE that I haven’t encountered before. Does anyone know what the issue is? Thanks.

Would you mind sending me a .zip of your game? If you can get it to me within the next few hours I’ll make sure I have a look at it before I’m away for a few days.

1 Like

Hi @CJW, thanks for the offer. I’m not sure how to get a zipped folder to you. Doesn’t seem to be allowed to be uploaded to gmail/drive. (Was going to try and send you a download link.)

I’ve also since added *image codes since it’s currently on dashingdons instead of image scenes like I usually would for compiling via CSIDE. Does this matter or would you need them commented out.

Unfortunately it’s the middle of the night here so just heading off. Don’t worry too much, sounds like you’re busy the next few days. I thought it might be a recognised problem.

1 Like

It’s not something I’ve heard of before, and not finding startup.txt is definitely not ideal :grimacing:

I’m out of the country this weekend, yeah. But if you could still find a way to get it to me when you can (in the format in which it fails to compile in CSIDE), it’d be really good to get to the bottom of it.

1 Like

Interesting… Ok. Not quite sure why it’s a problem, but I think I know what the problem is. I loaded up my files (written in notepad++) into CSIDE, exported them into a new folder. Removed any of my housekeeping files (I had a few unused files that had my story outlines etc in it). Then tried to compile it and it seems to have worked. It looks like CSIDE draws all the files in a folder out, not just the ones in the editor? (It exported the housekeeping files as well as the ones I had active.) Could the files in the package you download from COG’s site be interfering with CSIDE’s function? (I’ve never had this issue before but weird how it suddenly works once files are duplicated and exported into a new blank folder.)

Anyway, I’ll have to run through it and make sure it’s compiled all the scenes properly (no time this morning but will let you know when I can get time to do it).

Just while I think of it, CSIDE is still not playing nicely with notepad files to actually edit them in CSIDE. It doesn’t seem to always be able to recognise correct spacing of tabs and turns them into multiple spaces if you start changing things which breaks the file. Don’t worry about trying to fix it! Just letting you know in case anyone else has the same problem. It will run other functions (ie tests) as long as I don’t touch the file in CSIDE and due to the spaces/tabs error you get when starting up notepad++ files, there seems to just be something incompatible between the two programs.

1 Like

Correct. CSIDE will consider all .txt files in a project folder as part of the game and will include them in compilation. There’s been some debate in the past whether it should require a scene list to restrict these, but we’ve always swung towards avoiding unnecessary boilerplate where we can.

It’s definitely been reported before that people keep .txt files of notes in the same folder as their game and have similar problems (though they didn’t manifest quite like that). I’m certainly open to suggestions, but I don’t think there’s a perfect compromise.

As for CSIDE to Notepad++ compatibility, there isn’t much for it to be incompatible about. Both should be working on raw utf-8 encoded text files. You can specify other encodings with notepad++, so that might be something to watch out for (ChoiceScript should be utf-8 only). CSIDE does also have a smart/auto indent feature which works off your CSIDE indentation setting, it will NOT automatically detect whether a file is using spaces/tabs, nor the indentation step level (2, 4 etc.). So, if you open a spaced scene file in CSIDE but have CSIDE set to tabs, then yes, you may find it inserts seemingly incorrect spacing. Just turn smart indent off, or set the indentation appropriately.

The next version of CSIDE improves on this and will attempt to detect and set indentation automatically. Links to try that version out can be found in this post: [CSIDE] The ChoiceScript IDE (v1.3.3 Now Available — 05/09/2022) - #1235 by CJW


Not quite sure where to post this and I am unsure if it’s a Choicescript issue or a Dashingdon issue, but I released a Demo of my story on Dashingdon and some users are reporting back a “too much recursion” error. I don’t get that error but I’m assuming it has something to do with the images I put.

Is there a way to fix this while still having the images, or should I remove the images all together?

1 Like

That’s not a CSIDE or Dashingdon error, that means you have a loop in your game that’s cycling over and over.

Edit- did you add images as scenes? If yes then I have had issues. You need to either add them as *image (not as gosub scenes) or compile the game before uploading to dashingdons.

So I compiled the game and added in all the images as scenes. Ran through it locally a number of times and it seemed fine… but once uploaded to itch it errors out in a different way. I tried it on firefox and edge just in case it was a browser issue, but no joy. Any ideas please? (I’ve set it for download at the moment as I can’t get it to run when hosted on itch.)


Edit: Tried uploading the html file to dashingdons and it errors there also?

1 Like

Hmmm. Recursion may refer to recursive function (aka *gosub command), I guess?

Maybe a couple of your *gosubs are calling each other over and over without a *return in the middle to ease the stack. Overburdening the program.

Well, I may be wrong.

1 Like

Curious how images could cause that though. Would love to see the code.


I feel like I might’ve seen this reported before, but evidently it fell off my radar. I’ll take a look when I’m back in the country next week and get back to you.


Ahh okay! I will try that out then, thank you for the help!

Yup. It was definitely a gosub, I have a lot of them. But I am attentive to see if they do return, the only ones I had no control over were the images ones, but I have switched them to something else besides gosubs. Thanks for the help as well!

No idea either! I have never encountered the error, not even in Randomtest, but some people who tried my game were getting that, which is why I asked. But I do wonder.

1 Like

I have had this error when uploading to itch.io. I ended up using ChoiceScript’s built-in compiler through the browser, and the HTML file it created caused no problems.

1 Like

@Hazel @Jacic Thanks for your input. I think I have a fix for this. I’ll try and roll it out into a release later this week. If either of you are free and willing to test it as well, please let me know.


Sure thing. Thank you!

Sure, no problem.