[CSIDE] The ChoiceScript IDE (v1.3.3 Now Available — 05/09/2022)

Does CSIDE not yet support parameters with the *params command yet? I think it’s available in the latest update of ChoiceScript.

1 Like

Pretty sure the update on the development channel does … Let me know if this is not the case!

First off @CJW, I loves me some CSIDE. It streamlines the process for me and is very noob-friendly. And it’s been months since I had even the slightest hiccup with it that wasn’t caused by my own mistakes. But tonight I was trying to modify variable names on a couple of early chapters and they won’t save. Just spins forever. It will let me save the chapter I am currently working on, though. Any thoughts on what the issue might be? Or should I just download a new version and see if that cures what ails?

1 Like

Typically an i/o problem with the file. I’ve never experienced hanging myself outside of the web version, and in that case, it’s usually an issue with the Dropbox servers. If you’re having this issue locally, try: rebooting your computer, closing and re-opening the files, confirming your account has permission to edit the scene files (they’re not read only etc). This isn’t a bug I’m aware of, so I doubt updating would solve it.

The scenes or project folders don’t have any unusual characters in their names do they?

No, each scene is a one-word name, and they haven’t changed so I don’t know why it’d be an issue now when it was not before.

I put my computer to sleep and it was good after that, but now it’s happening again. I know closing and reopening CSIDE doesn’t change anything.

Sounds like this will need some deeper investigation, but we should discuss it further via PM. Would you mind sending me a copy of all your scene files, details of your computer specifications (os version etc.) and the version number from CSIDE?

I can also confirm that I’ve been having problems with scenes as well. I was starting up a brand new project and within the startup *scene_list, it will not recognize the name of a tacked on scene at times.

But, after deleting and remaking it, it fixed the problem. Maybe it’s a strange bug that happens from time to time? I’m using the developer version of IDE.

Could you please expand on this a little bit? What does ‘tacked on’ mean? And where does it fail, when compiling or when it comes to the *finish?

I apologize if my English was a little spotty when I said tacked on. :cold_sweat:

I meant added into the *scene_list and into the project files as a whole. It would normally fail for me when the program started, saying that “Prologue” could not be found, even though it was clearly added to the files for the scenes.

But I’ve only had that error two or three times in all, where it for some reason couldn’t find the scene. I tried to recreate it, but I wasn’t able too. It might have just been some weird bug that popped up?

Keep all your scene names to lowercase. CSIDE adheres to that, as it’s CoG’s standard guidelines.


Hi everyone, this is just a very quick update to say we have now passed over 1000 (1100~) CSIDE downloads across three platforms.

I just wanted to take a moment to thank each and everyone one of you for all for your invaluable contributions. It wouldn’t be half the application it is without you.

I’m making good headway through the issue/feature backlog on Github, and hope to push a big update over the holiday period. If there is anything that you’ve mentioned on this thread as a suggested improvement that isn’t listed on https://github.com/ChoiceScriptIDE/main/issues (check closed as well as open), please let me know and we’ll update the list.

Again, many thanks, and happy holidays!


If I had two wishes, the first thing I’d wish for is having access to this back when I was attempting to write Jewel in the East. The second is for a version that’s fully accessible on mobile.


Hi CJW! Thanks for the totally awesome program. I used to write in Notepad++ and while it wasn’t too bad, CSIDE is a definite improvement that I will be using permanently from here on-out.

I had an issue I’d like to report (sorry for not reporting it on GitHub but I can’t be bothered with trying to make an account on there at the moment lol). I encountered some issues with indentation once when I opened the program. CSIDE said that there were some spaces detected in my game (I use tabs) and asked if I wanted to correct them. I clicked yes, and then, as I went through my game, I noticed that my indentation was messed up entirely. This is essentially what happened:

blah blah stuff stuff
     #choice begins here at this indentation
     but then the text under the choice was at the wrong indentation

That’s about the best I can visualize this. I have a lot of choices nesting within some of my options and a lot of *if/*else statements, and all of that indentation was reduced. I had to completely re-indent everything. Not sure if this was an issue with the way I was indenting (I had some initial confusion because the default setting is spaces and I didn’t know that) or if it was a program issue but I felt that it should be reported.

Also, it’d be awesome to have a variable library that saves variables made with the *create command and lets you autofill variable names when you type *set. But that’s just something to think about :slight_smile: Thanks for the great program!


Hi trevers! I’m very glad to hear you’re enjoying CSIDE, and thank you for reporting the issue. I appreciate it’s lot of effort to submit to Github, posting is here is absolutely fine, just give us a nudge if no one responds to it (it’ll never be intentional), and we’ll eventually add it ourselves if we think it’s worth doing so.

You’re not the first and I doubt you’ll be the last to fall afoul of this… I implemented this check to give you a simple slap on the wrist if you had started to use four tabs, instead of four spaces, or vice versa. Anything more complicated than that will indeed cause CSIDE to create a real mess (and that’s why it was always optional, not automatic). “Fixing” this would require a much more complicated system that actually crawls through and tries to decide what your real intentions are, based on previous lines, but even this isn’t fool proof - no one is going to know exactly what indentation you intended (except you!). For the time being, I’m actually getting very tempted to turn this feature off, as it seems to be causing a lot more harm than good. Would anyone have any objections? An alternative would be to throw up a simple message, maybe list some culprit lines, without actually offering to fix it for you.

On the bright side, I have recently made a change to how visible tabs (and now spaces!) render, so that any combination of spaces+tabs won’t actually fill in correctly, making it a lot easier to spot and fix cases of mixed indentation manually.

Note the half complete lines (I’d be tempted to colour them differently as well):


This seems to be a hot topic at any rate, so I’m very keen to invite discussion on this. The only thing I will say is that rewriting a better auto-indentation detector is probably not going to end up high on my TODO list.


Thank you for the clarification! I think a warning message and culprit lines would be phenomenal to help fix those issues.

As for the indentation marking, I think the current version of it is sufficient! The issue I notice with the lines is that the dotted lines seem to be below the text on the line as opposed to next to it or in the center of it. For me, this would get super confusing. I imagine people with dyslexia might also encounter problems with a ton of lines. But it could possibly work! :slight_smile:


First of all just wanted to say many thanks @CJW for this awesome tool! I switched to using it on desktop and it is enormously helpful.

Question: I tried using the online version on my phone (Android) but can’t get it to work (can create projects but then can’t find them.) Is this just me, or is it because CSide is not yet mobile-friendly?

Thanks again for all your hard work so the rest of us can write quicker & better! :slight_smile:


Would you prefer vertical lines? I can probably make that an option, and will also look into moving the lines a bit higher.

Thank you for your feedback LadyCass, I’m really glad to hear it!

Opening a pre-existing project should work OK. Try creating one locally, then opening it via the web ui.
Phone support is really poor in terms of the UI, but it should be functionally sound.

I have been having no end of trouble with the web version since Dropbox shifted to its v2 API. Even on browsers it doesn’t seem to work properly half the time. When I get a spare weekend I’m hoping to replace the Dropbox dependency with @dashingdon support (or at least add this as the new default). I’m not sure how much work this will entail though.

I’m really sorry I don’t have a better answer than that right now, I’ve been nothing but disappointed with a lot of changes made to Dropbox over the past couple of years.


Let me know if I can do anything to help from my end with dashingdon.com. I’d be happy to tailor the API to your system requirements whenever I have some spare time.


Look at that community support!

*achieve amazing_person

My thanks to both @dashingdon and @CJW for your help. You’ve been invaluable. This is where I say that… Apparently.


Wholeheartedly agree. CSIDE and Dashingdon have both been invaluable in helping a first-timer create and make public his work, respectively.