[CSIDE] The ChoiceScript IDE (v1.3.3 Now Available — 05/09/2022)

According to help->changelog, my version is:

v1.0.1 - 14/06/17


What is your current update setting? I think 1.0.1 was actually a pre-release update, according to the changelog, so it’s probably the version that was released when the first public version of CSIDE went live back in June.

I don’t have anything to do with the technical end of CSIDE (I just make notes about things), but you could maybe try making sure you’re at least on the most recent stable update? Or maybe try the ‘Latest’ update, and see if that fixes the problem? I’m on the Development channel (not necessarily stable updates!) because I beta test new updates, so unfortunately I’m a few versions ahead of you.

Edit: You can change your update settings from the Settings Tab under ‘Update Channel’, towards the bottom and just about the Colour Scheme options.


Update was on ‘stable’. I was confused by the fact that AFAICT the latest on github is v1.0.1, according to Releases · ChoicescriptIDE/main · GitHub

But switching to ‘latest’ in-app fixed the problem! And also has night mode for IDE so I’m going to be sticking with that. :slight_smile:

Thank you for the help!


Just got this error. It was working fine earlier.

this might be due to an update (on development channel) is there any way of changing the channel without deleting and reinstalling it?

Sounds like a corrupt installation (not update related). Can’t think how it might have come about though. Any abrupt closures or shutdowns, or changes to your OS? Best bet is to completely remove the app and reinstall from the installer. I’d like to think this is a very isolated case.

Not that I’m aware of. It worked fine earlier then this evening it just decided it didn’t want to work. I’ll delete and re-install it. Thanks.

1 Like

If you really want to revert versions (doubt it’ll help in this case), go into the application folder and rename “prev-package.nw” to “package.nw” - prev is always the previous version, so you’re limited to one version rollback at present.

Okay its been deleted and reinstalled. It seems to be working again now. I’ve put it back on the development channel again. I’ll let you know if it happens again.

1 Like

Thanks for your feedback @GoldenSilver

CSIDE’s indentation conversion is far from perfect, and that’s why it’s an option to convert, and not done implicitly. It’ll only really work when you’ve accidentally indented a line in the wrong type, but to the correct level. Mixed tabs+spaces across the same lines are too ambiguous to fix automatically. It’s often easier to do it yourself if you know where the problem is likely to be (perhaps we could make this clearer in-app). Aside from that, just making sure that both Notepad++ and CSIDE’s indentation type (space/tabs) and width are the same, and then you shouldn’t have any problems. If you are, please let me know. I like / agree with most of your suggestion list, and will see to the tickets @Fiogan has submitted (If anyone is keen on seeing progress day-by-day, best place to check is Github). There are a few things there that (as @Fiogan noted) are down to personal preference, and may require a bit more thought to setting structure and options. Variable spell checking, for example, a lot of users actually like that.

At any rate, thank you again for the feedback :slight_smile: keep checking back!

@atiaxi I’m sorry about that, this was/is actually a known (but not very well advertised) bug introduced whenever patches are built on a Windows machine. I do all releases from Mac ATM, to bypass it. Day 1 release suffered sadly. Thank you for bringing it up, I should really get those binaries updated to more recent versions, or at least rebuilt packages.

@Nocturnal_Stillness Thank you! :slight_smile:

Hi, this might have already been asked earlier but I can’t find it so I’ll ask now. I’ve mostly been working in Notepad++ up until now and that had a useful feature that showed dots and dashes at the beginning of lines to denote spaces and tabs respectively. I was wondering if CSIDE had this feature and, if it does, how I could activate it given I’ve had a cursory look through the inbuilt tutorial and settings menu and haven’t found the option?

I keep getting a message saying there are spaces on a line that I repeatedly and manually replace with tabs and I just want to make sure I’m not going crazy and that there’s something I’ve actually missed.


@LaughablyAffable You can set tabs to show but not, unfortunately, spaces at the beginning of lines.

Setting tabs to show is here, in the Settings page, between spell check options and word count:

I had a similar weird problem with tabs/spaces, only in reverse (I use spaces), several versions of CSIDE back. It went away when I manually retyped the line in question, plus the line above and below it, in a separate section up above, then deleted the three lines right where the problem was. I’m still not sure if I’d created some sort of weird formatting error where I’d copy-pasted something, or what. Sorry I can’t be more specific—I hope you’re able to sort it!

I’ve also put up a request for showing spaces at the beginnings of lines, and an issue report with your error, up on Github so nothing gets lost in the post shuffle.

On a totally different topic: Is there a way to slow down the undo function, or is this a problem for anyone else? I’ll often type out a paragraph, then say hit enter a couple of times…then I’ll want to undo the pair of enters and half my paragraph will disappear. I’m not used to the word processor or text edit programmes I used in the bad old days doing that; it’d just undo a word or two, or maybe a line at most. (I did put this on GitHub too, no. 29.)


This isn’t impossible with spaces, but is a little more tricky. Hence why there’s only the tab option ATM. Happy to look into it.

There is… Though like many things, it’s all about finding the right balance that best suits everyone. Everyone types at different speeds, for example. If it’s the general consensus that it’s not aggressive enough, I’ll be more than happy to change it. So please feel free to discuss/share opinions on this.

Couldn’t say much on the tabs/spaces issue… It’s certainly not something I’ve come across. If anyone has a way to reliably reproduce it, I’m all ears!


Thanks for all your help, people.

I think the Tab/Spaces issue was just another case of my not going through the settings thoroughly enough. I had the Tab Type setting switched to space so every time I pressed the Tab button, it was actually just putting in four spaces and, because I hadn’t switched on Visible Tabs, I couldn’t tell the difference. Things seem to be working now.

Thanks again.


Encountered a bug. Accidentally created a scene I didn’t need, but when I try to delete it, I get this popup (after confirming I wanted to delete it): 03 PM
This is a completely blank scene, still called untitled.txt

1 Like

@Alexandra Thanks for reporting! I put the issue up on GitHub as well so it’s easier for the ‘CSIDE team’, as it’s been named, to keep track of the issue/progress on it.

@CJW I think this is the same issue I had a little while back, if I’m remembering correctly? I didn’t see it on GitHub though (sorry about that), in either the open or closed issues, so I went ahead and posted it.


Thanks for reporting this. Are you on a Mac? What version of CSIDE are you on? I think the latest version on the development channel fixes this. Please let me know if that’s not the case.

Specifically, the fix is here: https://github.com/ChoicescriptIDE/main/commit/8fcb4557384995001afc731e790e3978a244e05f

But I can’t remember if the current build is reflecting of that (it certainly won’t be on latest/stable - but should be on development). I’m due to move everything down (new dev, latest -> stable etc.).


I’m on a Mac, with the update channel set to latest (1.1.0).
By the way, I’m working on a save system creating and then translating a ~70 digit string, and I cannot imagine debugging this without the console and the step function. Thank you for making this wonderful tool!

1 Like

Try setting it to development, and download the latest update there - that should fix it (@Fiogan can confirm, but I don’t believe we’ve found any really nasty bugs in the latest dev version?). If you do have issues with it, you can always manually revert :slight_smile:

Oh, excellent! Thank you for sharing that, it really does make all the work worthwhile! Good luck with the system, and let us know if there’s anyway we could further improve CSIDE to help!

It worked! All gone now.

The last thing I find myself swapping back to Atom for is a search and replace function. Copy-pasting on CSIDE is a bit tedious when I decide to make a big change like a variable name. It’d also be nice for auto-replace to remember variable names from other scenes in the same folder.


CSIDE has search and replace, although it only works for one file at a time and not all files in the project (@CJW, is that something that could be a future possibility, find/replace for all files in a project? I know someone’s mentioned that before). The list of search and replace functions is under hotkeys in information—I know there’s heaps of stuff in the helps, though.

@CJW No major bugs in the dev version as far as I know! I’ve been using it daily since it went out.