CSIDE replacing words

I’m using CSIDE to program, but I’ve run into an issue where when trying to replace words it’ll type over the previous words instead of adding new words.

So if I want to re-word Apple Sauce with Orange Juice the O will replace the A, instead of both remaining until I erase either, and due to Orange Juice being longer it’ll eventually begin to cut into other words and whatnot. It’s pretty annoying to have to rewrite entire sections of text due to correcting a minor spelling error, and I’m wondering if anyone else has this issue

1 Like

So, you don’t want the word “Apple Sauce” to be removed?

Just type in “Apple Sauce Orange Juice” instead in your replace with section.

FYI, replacing words is the intended function and behavior.

As for cutting the words outside of the ones specified in your search menu, it maybe is a bug. (Solved)

P.S. I borrowed the terms from Notepad++. If CSIDE used different terms, sorry for the confusion.

1 Like

I don’t really know how to explain it, I’ll try and make a video or something

1 Like

It sounds to me like you’ve accidentally hit your Insert key, turning insert off. You seem to be describing the effect that would have in any text editor, not just CSIDE’s editor.


That fixed it, thanks!