"Couldn't load scene file" SOLVED


#1

Hey, I’ve just started out and wanted to make a test scene called “untitled”. I added it to the scene list in startup.txt, but when I refreshed the game it said “Couldn’t load scene file: scenes/untitled.txt. The file is probably missing”. The other scenes (animal, startup…) I can edit and play with just fine, though.

I’m on a mac and opened the file from CoG using Archive Utility.
I saved “untitled.txt” in the scenes folder.

Any insights on why this isn’t working would be much appreciated!


#2

It sounds like you’ve either got a typo in either the scene name in the scene list or in the name of the .txt file. Or have you perhaps written one of them with a capital letter and the other with a lowercase letter? ChoiceScript is case sensitive, so that could lead to errors.


#3

That type of error will pop up if one of the listed scenes has no txt file to find. If their is no txt file with the same names that are listed under the scene list in the start up file, then the error will pop up. as well.


#4

The file could be spelled wrong or placed on the wrong file. Double check it to make sure it correct and it should be a .txt file, but you write the name only for the start up file.


#5

I believe it will also show you this error if you have created the file, but it is empty.


#6

Huh. I tried again (without typos) and it’s the same problem. But when I tried saving the file again it said it can’t have the extention .txt, but .txt.rtf. This happened the first time also, but I thought it was no biggie since it had txt in it. If this is the problem, do you guys know how to fix it?


#7

Yay, now it works! I just had to change the default settings in TextEdit to txt, plain text. Thanks for giving me advice!