Can't load Choice-Script?


#1

Hey, I recently posted about ideas on starting a game. Today, I attempted to download Choice-Script with no avail. I clicked on web then index, like it explained, but instead of starting right away it put up a screen saying “File not found”. I’ve tried uploading Choice-Script with Explorer and Firefox. Is there another program I should use or am I not clicking on the right file? Any help would be lovely.

Thanks lots,
Mango


#2
  1. Okay, first you want to download the actual ChoiceScript:

http://github.com/dfabulich/choicescript/zipball/master

  1. Unzip it somewhere (if in doubt, the desktop makes a good place, that way it’s always reminding you that you have work to do). (Pretty sure that this is mandatory).

  2. Now your going to navigate down to …web/mygame. This is where your game will be located.

  3. You’re clicking on the Index file here?, First off: with the newest build of ChoiceScript, it does not run in Chrome unless uploaded to a site, so try Explorer (Personally I’ve had the best luck with IE, as error messages seem to come out garbled in FireFox, although that may be fixed with the newer builds).

You may just have a corrupted download (happens all the time no matter what your downloading, just redownload and try again) If you’re still having problems, can you give a more detailed step by step of what you are doing?


#3

@Reaperoa
I’m sadly still having problems. I clicked the link, opened, allowed, and then clicked web, mygame, then index. I got a screen that said My First ChoiceScript Game at the top. Under that it says Show Stats and below that it says Loading… but it never seems to load. I, again, tried this on both FireFox and Internet Explorer.


#4

@Mango (sorry for taking a while to get back)

I’m having trouble figuring out what is going wrong so:

  1. Are you actually unpacking the game (as opposed to trying to open it in the zip file)?

  2. Try to clean your browsing data before attempting again (cookies and cached data). I’ve noticed that CoG like to stay in your data and end up playing the old cached versions sometimes (noticed this while trying to update the game on my site).


#5

@Reaperoa

It’s fine. I’m not really a technically person(when it comes to unzipping files and what not. The program itself I should be able to work just fine)what’s the difference between unpacking the game and opening it in the zip file?

I deleted the cookies, the same screen comes up when I go to Web, MyGame, Index, but that screen also comes up when I go Web, Index. Not that that helps much…


#6

I’m using Windows Vista PC by the way


#7

Okay, note that I’m working on XP, and have never used Vista, so some things may be slightly different from what I say. Locate the file you downloaded, and open it. Now, on XP there is a big blue bar on the left side of the window with a number of options. Somewhere in that bar is the words “Extract all files”. If that does not seem to be the case, look for something similar (Specifically, look for something that says “Extract”). What you want to do is extract everything to your desktop. The ChoiceScript engine does not work when still packaged in a zip file, once it is extracted, it should work fine though.

If that does not work, I sent you a PM.

(BTW: The index file in the “Web” folder leads to the same place as the one in the “MyGame” folder. It just makes it easier to keep everything neat when actually uploaded to a site AFAIK.)