Using ChoiceScript on a tablet

Hello, I am facing a lot of trouble in finding a way to use choicescript on a tablet. I tried the CSIDE but it either just crashes after two lines or doesn’t run the code at all.
Is there a way to use choicescript on a tablet or is it only possible on a PC?

1 Like

I thiiiiink if you got Firefox or Safari as browser on the tablet and a decent text-processor you should be able to.

1 Like

Yes I tried to run it on Firefox but it didn’t work not even the older versions.

1 Like

that’s peculiar. Was it not working to begin with or did you get an error? (I don’t mean CSIDE, just to make sure, but the quicktest/randomtest etc)


It works as long as I don’t erase a character and when I do then it simply freezes


Okay… i think THEN something’s oughta be wrong with your tablet, not Choicescript.

1 Like

It does not work on my phone either. I have not tried it on a PC yet, hopefully it will work.

Okay, wait.

What exactly are you trying to do?

Choicescript is just txt files. you don’t need to alter any of the html or script files, just the text. (everything in the scenes folder)

Sorry if this sounds belittling, but we had people who weren’t aware of that and tried to alter the html etc files instead of the txt


Continuing the discussion from Using ChoiceScript on a tablet:

CSIDE works fine on PC (what a relief that was!) but it doesn’t work on my tab.
Here is an example:

This error doesn’t want to go away, I used the same code on the PC and it is working perfectly.
And don’t worry about belittling, I am new to coding in general and this is my first experience trying to create something.
Edit: it won’t let me embed media:(
The error was “expected option starting with #”


The error means you made a *choice somewhere and forgot to add an # before an option of got the indents wrong
choices usually are formatted like this:

      option text
      *goto label1
      option text
      *goto label2

or *fake_choice which doesn’t need a goto but will continue with the text below the choice-body

And embed media where? in the game or in your post?

1 Like

The indentations are all correct. I ran the same code in PC and it worked but didn’t on my tablet. Is there some settings that I need to fix in CSIDE or my browser?
I included a screenshot to give you a better idea but it didn’t go through.
Also thank you for giving your time to help!

Best suggestion I can make here:
When you wanna work on your game on your tablet, load the txt files from your pc and work on them in a decent wordprocessing program. You should be able to load those into cside then to fix errors


Today I discovered that my tablet and my other phone have some problems because CSIDE works just fine on my friends’ phones.

1 Like

This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the moderators.