Using Bug Checks


#1

Could someone write an idiots guide to using the bug check tests here? I’m getting nowhere trying to use them!


Need help with Quicktest and Randomtest, it's not working
#2

Quicktest and Randomtest?

First off you need to be able to use command prompt (for PC). Once there, you switch to the directory where your game is. Here is how I do it on my game:

cd documents
cd choiceofgames
quicktest

Note: the folder where your game is located must be mygame. For the purpose of loading the game to the Web, I remained it zombieexodus and the two bug testing features wouldn’t work.

Also randomtest can take a long time to run so I suggest limiting the tests by typing randomtest 5 (which tells the system to stop after 5 tests).

I found that my PC did not have .net framework installed, so I had to do that first. If you are having other problems or have errors, post them here. I had a lot of difficulty getting them to work, but once done, they are invaluable.


#3

After a lot of playing about I finally got them working. My problem was a java issue. I solved it thanks to a thread on the google group page here:

http://groups.google.com/group/choicescript/browse_thread/thread/e2b1c2d08b16b1a9/415ed2ca8e51213d?lnk=gst&q=using+cmd#415ed2ca8e51213d

And a link from that page here:

http://introcs.cs.princeton.edu/java/15inout/windows-cmd.html

This allowed me to run the tests successfully in cmd (using windows7)


#4

@andymwhy
I think I am having the same problem. I followed the links, but still couldn’t get it to work. Here is what command prompt displays:
`

C:\Users\Madison\Desktop\dfabulich-choicescript-4140592\dfabulich-choicescript-4140592>echo Executing randomtest, writing to randomtest-output.txt
Executing randomtest, writing to randomtest-output.txt

C:\Users\Madison\Desktop\dfabulich-choicescript-4140592\dfabulich-choicescript-4140592>java -jar js.jar randomtest.js 1>randomtest-output.txt
‘java’ is not recognized as an internal or external command,
operable program or batch file.

`

I am currently just letting my little brother play through over and over till he runs into an error, but it takes forever.


#5

@monkey I installed this Java file:

Java Platform, Standard Edition Development Kit (Java SE 6 Update 27)
http://www.oracle.com/technetwork/java/javase/downloads/index.html

from the second link and got it working from there. If that doesn’t work, read the FAQ section at the bottom of the second link. That might help too.


#6

Hello, new here. I would really like to get a grasp of how to use these tests. So far, i have tried the different approaches listed here, but i still get the same error as monkey. If someone could make a step by step guide with no ambiguity, i would be really grateful.
So to recap. I can use cmd, but the tests cant recognize java.

(sorry for necro, but i think thats better than making a new topic) :slight_smile:


#7

As a help to all who later might be watching this thread for help, i discovered that downloading standard java 62-bit solved my problem. java 32-bit does not work, for some reason. Cheers!