Help - quicktest problems with a second game


#1

I’ve been limited in what testing functions I can use, since I’m on a Mac. The .html version of quicktest works, and the .html version of randomtest sort of works (although for some reason it never listens when I ask it to automatically scroll to the bottom.) So, I’ve been using quicktest, manual editing, and play testing to find bugs.

For my CSComp entry, I made a second Choicescript folder, figuring that I would need to be able to test it from there. (I called the folder Choicescript2). But whenever I try to run quicktest, it hangs up and says “Loading” and doesn’t go anywhere. Randomtest asks for the usual variables, then gives me a blank screen.

I tried moving Monsters of New Haven High temporarily to the second folder, my CSComp game to the folder I’d successfully tested that from, still no working test. If I put both games in the same Choicescript folder, it doesn’t give me an option for which to test, just successfully tests MoNHH and ignores the other one.

Please help. I am very confused.


#2

I kept all the folder names the same for my second WiP for the CScomp, (exception for those in the scene) folder. Make a copy of the dfabulich-choicescript-f6e3c4d folder and move the copy to a different location. Have each WiP separate. Your quicktest and randomtest should work then. That’s how I did it. (I also have that problem with randomtest as I’m using my phone. Must demand a windows desktop to work properly? Just speculating ).

Hope that helps you.


#3

@Sashira I’m pretty sure what @Silverstone is right. But the similar problem that I was having was the result of using Internet Explorer instead of Firefox. If you ask the test to run in Firefox (or make it the default browser if you can’t specify what program to open with), the tests seem to actually run. Of course, I’m using a PC instead of Mac and I only tried it with the example game.