Test not running


#1

I’m working on my first real game and I’m trying to test what I have but every time I try this box pops up.

Here’s what I have so far. I tried to find an existing thread with no luck. Please help.

    *title Shadows

*scene_list
    startup
    sire
    coven
    mate
    danger
    romani
    migrate

*create name ""
*create gender "unknown"
*create humanity 50
*create brutality 50
*create skill 50
*create magic 50
*create wounds 0

*comment wounds can be reduced based on feeding
*comment when wounds = 10 you die

 You leave your little apartment as the sun sets.

 Two hundred years have passed since your sire brought you into the magical world that has always laid just behind the surface. Just past the glare of the sun is where you make your home and just past the perception of the humans you reign over a sliver of night, stalking the shadows.
 It begins to drizzle outside as you step onto the street. You allow yourself to be carried down the sidewalk by the waves of people that are still active, almost oblivious to the darkness above them with the harsh artificial light all around them. It's made it easier for you. No one believes the tales of the boogie man, the hushed whispers around a fire of the hungry pack that waits just out of the reach of the light to come and make a meal of you.

 You smirk as you drift out of the crowds and into the nightclub. The hunt is on.
*goto Club
 
*label Club
 Inside the club you can feel the thud of the base in your chest. Music sure has changed since you were turned.

 You scope out three possible targets; a goth girl in black and silver by the bar, a guy who most certainly used a fake I.D. to get in and is high as a kite, and the DJ who's hands are flying over their equiptment.

 Who will you pick tonight?
*choice
    #The Goth girl, some broody looks and a flash of fang and she'll be begging you to drink.
    #The guy, you love the feeling of a second hand high.
    #the DJ, music is a passion of yours

#2
  1. You’re indenting after your *comments and *label. Remove those. Your *title is also indented. Remove that too.

  2. That said I don’t think that’s your problem at the moment. I’m pretty sure your error is from deleting files, or copying them over wrong (or occasionally Windows’ antivirus going paranoid).

  • a) Download CS again
  • b) Unzip the entire zip file
  • c) Copy over your scene files
  • d) Try running it again

#3

Ok, thanks. I’ll try that.


#4

@Reaperoa tried what you said but now I’m getting this error message


#5

Is title still indented? Is that file correctly named startup.txt? If you think you have a startup file but there’s a typo in the file name, the tester will be confused.

If it still throws up weird errors after checking those two things, could you have incompatible punctuation? For example, if you write something in Word and then import it to Notepad as plain text, it will look like it has carriage returns between every line, but the code won’t actually know they exist.