Syntax Highlighter not functioning


#1

Hello there-

I’m a very new author that just started a WIP and I’m unable to get the syntax highlighter to work. I am following the instructions on the “Notepad++” page in the wiki- I downloaded choicescipt.xml, put it in %APPDATA%\Notepad++, then closed the program and reopened it. Choicescript doesn’t show up in my list of languages, and I even put the .xml file in the appdata\notepad++ folder for both of the user accounts I have on this laptop. I’m using Windows 10, but I also had this problem on my tower, which is running Windows 7.

If there are any other details I can provide please let me know, I’d appreciate any help in this matter. I’ve spent about 16 hours over the last three days learning Choicescript and getting my first work started, and I’ve pretty much spent that whole time fantasizing over how much of an easier time my bad eyes would have if the highlighter worked. Also, sorry if I’ve posted this under the wrong category.


#2

Hi, I believe you have to import it by choosing: “Define your language”, and then importing the choicescript file.
Then you select choicescript at the end of the list.

Tell me if it works or not :smiley:


#3

That worked! Maybe I’ll see about adding that detail to the wiki page so the instructions are more clear.

Thank you so much for your help!


#4

You’re welcome, that’s what we’re here for :wink:

Good luck with your work :smiley: