Spaces and tabs on same line...even when it isn't?

Despite four attempts to fix it, the problem still exists and as far as I can tell, only when people try one specific line, yet it worked just fine when I tested it, and I can’t see any obvious issues with it.

The error I’m getting is:…

My code looks like this:
*if (Shell = “Human”) #“Humans are way too weak. I’d rather be wolfkin.”
This body. The flesh. So…fragile. Needing to give everything it could sacrifice in order to secure victory. What would have been the result with something that wasn’t so weak? More strength, speed, sharper senses. All things that could have potentially caused a different outcome. Which is what’s needed. If I hold on to this weakness then it will be the thing taken with me forever into the grave.

	"'ll look like won't really make you...." The wolf won't finish her sentence as she gets to work on the latest development. The ranger helps carve some runes, though the wolf mainly takes the lead and it's much faster than before for the magic circle to glow.

	When the rattling comes, it signals that it's finally come to proper life. Then an inch of movement with the fingers. Then the full movement of a hand. Much faster than before. Not any less painful. The two do not make an ideal combination with each other.

	"Gah..." Trying to get the words out is blocked by a sharp pain in the lungs and coughing only amplifies it. None of them get any closer, instead just watching things unfold. The human girl seems just too much in awe to act, the wolf too apathetic, the servant too accessing and the ranger simply too proud.

	Then the sudden sharpness of pain again. Sharp slicing through the fingertips pushing it's way past the boundaries of skin and jutting out as sharp and lethal. Sounds...sharper. Each footstep and breath from everyone here. Amplified. So...obvious and impossible to ignore. Even the feeling of ears twitching alerts them to their own actions is a vicious cycle that forces my own heart to beat, alert and ready.

	More importantly, then the bushiness of a tail sweeping from behind...the scents. Why are there so many things? Too sweet, too bitter, spicy or cold. How can any of this be ignored? All of it just so overwhelming. Is this what it's like for Kaja? How can she pay attention to anything when everything begs you to run off in every direction to investigate whatever the source of that god awful scent is?

	"Wow. That worked!" The human girl...dam. Could her voice be any sharper? Even Kaja has to wince a bit while listening to those obnoxiously high pitched tones.

	"'ll probably need time to get used to this." Kaja's always sounded so flat and filtered before..but the inflections. They seem more distinct than before. Almost like she's happy.
	*set Shell "Beastkin"
	*set Physical %+10
	*set Spells %-5
	*set Command %-5
	*goto doc2
1 Like

Yep, pasted you code in Choicscript IDE. If you go by arrow keys before each paragraph you will see. There are space before “When the rattling…” and space before “Gah…”

It’s not there. No spaces. That part is indented fine. I think it just doesn’t look like it when I post it here. Maybe a screen shot would work better?

Yeah I think I was right the first time between your lines are spaces

<tabRandom text
 <here's the space
<tabRandom text

Yeah, I think @kashidol is right and I’m on wrong, went a bit too fast on answering.

Yeah. That SHOULD be the issue, logically, but sweeping through the whole chapter, there are no spaces in weird places from using the arrow key system. I might just be missing something but I need to come back to this later to verify more. As far as I can tell, nothing is obviously wrong.


*if (Shell = “Human”)
     #“Humans are way too weak. I’d rather be wolfkin.”

The *if for a choice wants the option to be on the line below it, not on the same line (unlike *selectable_if). Not sure if that’s causing this particular problem, though.


You can also try selecting all your texts (ctrl + A) and see if there’re any lonely space on any empty line breaks. Otherwise, it’s always a good idea to activate whitespace-marks visibility on your code editor.

Here’s what it looks like on Notepad++

I’m not sure. I used the same format in scenes in prior chapters without any issues, so I really don’t think that’s it and after trying it in playtesting, that doesn’t work either.

I feel like I’m missing something very basic but none of the obvious solutions seem to be working.

Yeah, you’re right. It’s best format not to put *ifs on the same line as the #option (as explained at the bottom of this page:, but you are right that it wouldn’t cause a spaces/tabs error.

1 Like

Not sure if it’s related, but I get a lot of “mixed tab/space” errors when copy/pasting using Atom editor, even when there’s no indents involved. Usually I end up having to backspace out all tabs/new lines and redoing them before it will work. Most likely has something to do with the editor settings, but I figured I’d share my input.

Having whitespace characters visible should help locating the problem, I believe.