[Solved]Can't solve increasing indent not allowed


#1

I am getting this error:
Error: startup line 48: increasing indent not allowed, expected 0 was 1

But after several changes to line 48 (even deleting it), I wasn’t able to solve the problem.
Help, anyone?

(If the script is needed, I’ll post here.)


#2

just get rid of the single space you used at the beginning of the line. that ought to do the trick.


#3

Yea if that doesn’t work post it so we can see.


#4

Then I get:
Error: startup line 42: Expected option starting with #


#5

choices go like this:

*choice
  #choice1
     text and stuff
     *goto something1
  #choice2
     text and stuff
     *goto something2

#7

I use tabs, so when I post here, it srambles.
I’m using the template in https://www.choiceofgames.com/make-your-own-games/choicescript-intro/


#8

a tab is just four spaces, really.

and also, if i may say, your stats in that snippet you posted seemed… quite messy.


#9

Try this

*title Track of Time
*author Henry Schulz
*scene_list
    startup

*create name "Unknown"
*create gender "Unknown"
*create knowslogic false
*create knowsknowledge false
*create knowssociability false
*create knowsstrength false
*create hascrush false
*create inrelationship false
*create logic 100
*create knowledge 100
*create sociability 100
*create strength 100
*set logic 0
*set knowledge 0
*set sociability 0
*set strength 0

You're in a long black tunnel. You can feel cold, but you also feel heat. You feel tired, but hyper at the same time. Your eyes are closed, but you can see everything. You try to think, but your head hurts so much! You try to walk, but then you fall to the ground. It has a weird texture, like nothing you've ever seen.

You wake up screaming. Such a headache! You feel dizzy for a while, like if you were spinning on a rollercoaster. You are sweating. Must've been a horrible nightmare! You feel hot. You go open a windows.

What's your room like?
*choice
    #Clean, well organized.
        *set knowssociability true
        *set sociability +10
        You like to think that people come to your room and see everything in place, causing a good impression.
        *goto player
    #Messy. Easy to trip over something.
        You don't care what people think about you. You know how to find in your room and that's what
        *set knowsstrength true
        *set strength +10
        *goto player
    #The floor's clean, but my table and wardrobe are a mess.
        You like to keep things organized, but not much, not caring much to what people think.
        *set knowslogic true
        *set logic +10
        *goto player

*label player
And you? What are you like?
*choice
    #I'm a guy.
        *set gender "Male"
        *goto gndr
    #I'm a girl.
        *set gender "Female"
        *goto gndr

*label gndr
And your first name? Or at least your character's?
*input_text name
*goto pname

*label pname
${name}, Is that right?
*choice
    #Yup.
        *goto continue
    #Oh wait, got that wrong.
        *goto tagn

*label tagn
OK, try it again.
*input_text name
*goto pname

*label continue
*finish
*goto pname

#10

Then I get Error: startup line 47: increasing indent not allowed, expected 0 was 1


#11

That’s weird, when I run it I don’t get an error. And line 47 should be a *choice so it shouldn’t even have a space. Out of curiosity, what are you using to edit your code?


#12

Notepad.
I’m now trying to use WordPad.


#13

… isn’t wordpad even worse for this type of thing?

i would suggest notepad++ with view>show symbol>show white space and tab enabled, unless notepad already has that functionality. saved me a lot of grief.


#14

Yea you want to use something like notepad++ because it displays the line numbers, which is vital for fixing those errors.


#15

Yup. figured that out now. I wanted to see if it was an incompatibility or something.


#16

for future reference, it can’t be incompatibility since you are just editing a basic .txt file regardless of what you use to do so.


#17

Funny. After I closed everything and ran randomtest again, it worked.
Must’ve been a cache problem.
Thanks for the help.


#18

no problem! i would suggest, at this point–that is, while your game isn’t too choice-heavy–to just open up your file and do your tests manually, or do a quicktest instead, though. it’s a bit more convenient.