Scene dosent exist, but it does

The error I’m getting is: I’m attempting to finish my startup scene and move onto the next scene. I’m currently using IDE.

Ive checked and the scene does exist with a text files in the correct folder. This is the startup file

and this is the second scene I want to get to.

Any help would be greatly appreciated!

Is the scene saved in exactly the same text (including captials?)
If yes, try *goto_scene training and see if that works.

Edit- Actually might be a coding issue. You need a fake_choice not a choice if you’re not going to *finish under the choice branches themselves.

Already tried that with the goto_scene and yes both are the exact same spelling and capitalization

Sadly didnt work. Still gives the same issue that the scene dosent exist

Did you try *fake_choice? Sometimes weird error messages get thrown up on occasion.

Yep. Sorry wasnt clear, that fix didnt work

1 Like

Could I possibly see your scenes and project list on the left side of the IDE. I want to see the exact spelling of your scenes. The list looks like this.


because goto_scene training should work.

Just out of interest, you’ve got a finish at the end of the second scene, but no more scenes for it to finish to. I don’t think that’s the issue, but you could try taking it out or adding another scene.
(I really don’t like the finish command, it causes bugs if everything isn’t just so. I find I have less issues overall with goto_scene as at least I (and the game) know exactly where it’s pointing to.)

added a “whatever” scene and set it in the scene list, sadly didnt work.

1 Like


At the end it should look like this. There should be no finish just *goto_scene training
The error states the txt file does not exist. do you have a .txt file in your choice script folder named training? if so make sure there’s only 1 that has that name.

I literally just deleted it and remade it. it worked, even with a finish command instead of the goto_scene training

Im sorry for waisting yalls time :skull:


That’s okay. that’s what the forum is for!


No probs! That was actually going to be my next suggestion even though it shouldn’t be a fix really. I had one a couple of weeks ago where I literally made a new folder and copied the files across and the bugs disappeared. (Still have no idea what the problem was but at least it fixed it.)

1 Like

This topic was automatically closed 24 hours after the last reply. If you want to reopen your WiP, contact the moderators.