Save manager and editor for Steam (open-source)

I’m unfamiliar with screen readers. Is this a feature of Windows?

PS. Oh, sorry I understand now. I am not sure that Unity game engine supports screen readers. I’ll check it out and edit this post with my findings.

PPS. Yes it seems possible with a plugin. For the time being, I won’t be able to work on this save manager for an unknown while due to my busy schedule but who knows, I may give this plugin a shot in the future.


Hey, anyone having issues with ZE:SH? I’ve had no issues using it in the past, but I seem to be unable to edit my save on my newest playthrough.

Did it get updated? I haven’t tried playing any CoG games since the update to the code, and wondered if it would break the save manager and/or plugin for firefox that has a back button and saves. I need to check it.

Are you able to see and edit the variables or do you immediately encounter an error when clicking the Edit button?

Immediately upon hitting the edit button. It says something like “IndexOutOfRangeException”.

I rarely encounter the same issue too but couldn’t solve it because I think this is a bug in the game engine I’m using. After closing the error popup, I don’t encounter the same error for a long while. Is it the same for you or is the error consistent every time you click the Edit button? If it is consistent, could you copy the whole error message and send it to me?

I have the same problem in lords of infinity

Is this the same IndexOutOfRangeException error? After closing the error, can you continue editing stats as usual? PS. Sorry didn’t notice your private message. I’m checking it out now.

Hello, @yasirkula! I can confirm that this error started appearing around 2-3 weeks ago. I was a bit confused myself because it happened for every newer game at that time (Top Villain: Total Domination and Forbidden Magic), it worked well for the older ones. It happened every time I tried to edit the files (right away from the beginning, no actual edits involved yet) and the error was always identical (please, see below). However, today I purchased Path to Knighthood and everything seems to be working well. Out of curiosity, I created new saves for the aforementioned games and it works properly now. The older saves/autosaves just will stay corrupted.

EDIT: Spoke too soon. Just completed character creation in Path of Knighthood, saved it and the Unity fairies screamed at me again. Identical error, tried deleting all saves and restarting the story - same issue every time I try to edit it.

IndexOutOfRangeException: Array index is out of range.
CoGSaveManager.JsonSaveData.FindEndIndexOfValue (System.String json, Int32 valueStartIndex, System.String& valueWrapperChars)
CoGSaveManager.JsonSaveData.FindEndIndexOfValue (System.String json, Int32 valueStartIndex, System.String& valueWrapperChars)
CoGSaveManager.JsonSaveData.FetchNodesFromJson (System.String json, Int32 jsonStartIndex, Int32 jsonEndIndex, Boolean isRootJson)
CoGSaveManager.JsonSaveData..ctor (System.String json, Int32 jsonStartIndex, Int32 jsonEndIndex)
CoGSaveManager.SaveEditorWindow.Show (CoGSaveManager.SaveEntry saveEntry, System.String saveFilePath)
CoGSaveManager.SaveManager+<OnSaveEntryClicked>c__AnonStorey5.<>m__1 ()
CoGSaveManager.LoadConfirmationDialog.<Awake>m__1 ()
UnityEngine.Events.InvokableCall.Invoke (System.Object[] args)
UnityEngine.Events.InvokableCallList.Invoke (System.Object[] parameters)
UnityEngine.Events.UnityEventBase.Invoke (System.Object[] parameters)
UnityEngine.Events.UnityEvent.Invoke ()
UnityEngine.UI.Button.Press ()
UnityEngine.UI.Button.OnPointerClick (UnityEngine.EventSystems.PointerEventData eventData)
UnityEngine.EventSystems.ExecuteEvents.Execute (IPointerClickHandler handler, UnityEngine.EventSystems.BaseEventData eventData)
UnityEngine.EventSystems.ExecuteEvents.Execute[IPointerClickHandler] (UnityEngine.GameObject target, UnityEngine.EventSystems.BaseEventData eventData, UnityEngine.EventSystems.EventFunction`1 functor)

1 Like

Could you create a manual save, navigate to “CoG Save Storage” via File Explorer (Documents by default) and find that manual save’s “storePS_GAMENAME_PSstate” file in there and share it with me via private message? I couldn’t reproduce the issue in a few recent games I’ve purchased and would like to see a problematic save file for myself.

Of course, just sent it in PM. Let me know if I can help in any way! :saluting_face:

1 Like

I just recently started using windows and am having trouble accessing save file for individual files. I haven’t finished the entire game, so that might be part of the problem. Any help or tips you can offer would be much appreciated!

I have the same problem with Fallen Hero Retribution. Just a short time ago, everything was working fine.

I’ll take a look at it when I get the chance. This is a high priority for me.

1 Like

@BubbaJubbs @Jojn @MissGray @EkemRoht I’ve released an update that should hopefully resolve this issue: Releases · yasirkula/UnityChoiceOfGamesSaveManager · GitHub


If you’re trying to find the save files in file explorer, you can simply navigate to “CoG Save Storage” (Documents by default) and find the game’s directory in that folder. It can be hard to distinguish automated saves so I’d recommend creating a manual save if you’re trying to pinpoint a specific save.

1 Like

Thanks for all of your work! I apologize for not getting back to you originally, university has kept me very busy.

1 Like

Hi, thanks for responding at all! But, do I have to finish the game beforehand to access the saves, or can I access saves for individual chapters when they’re saved? I’m trying it with Sabres of Infinity and I only received my computer a couple weeks ago and am unused to using it. Any help you can provide would mean the world to me, thank you!

Ah, yes you need to play the game with the save manager open in the background. Otherwise, save manager can’t create the save files. Save manager is independent from the in-game chapter save systems BTW.

It is. Thank you very much!

1 Like