Random testing - intext picture


#1

Hello everyone,

so I am back with a question. I am random testing my game and at one point I include a picture in the text. It should be correctly labeled.

*image CS_house.jpg center

But when testing, it doesn’t come up. Is this just a common thing or is it possible I in fact labeling it wrong?


#2

Try using lowercase for the file name and make sure the picture file is in your mygame folder


#3

Used lowercase for the file and checked it’s in the mygame folder and it still didn’t come up. Both Random test (100 iterations with full text showing) and quicktest passed.


#4

I could be wrong but doesn’t it have to be a PNG file?

All of my images are PNG and they show up fine.


#5

My PNG images work fine too, but CoG’s own examples for this command use .jpg so unless that’s wrong…

The only other possibility I can think of is that ‘center’ is actually the default so is not needed. CoG’s examples use only ‘left’ or ‘right’.


#6

Try .jpeg instead of .jpg


#7

Oki doki, so I tried the jpeg ending and it gave me an error

Error: startup line 149: File does not exist: cs_house.jpeg

And I converted the file into png and got rid of the center alignment and it still doesn’t come up. Is it possible, that random test just doesn’t show the pictures?


#8

I have PNG files included as interior artwork and randomtest doesn’t give me any error messages.


#9

Woah, just reread your post, no I don’t think the image will actually appear during a randomtest.
Does it appear when you’re playing your game?


#10

Oh right. That would make sense. Well, I hear a lot of people being able to play through their games but I have no idea how to do that. Would you mind enlightening me on that matter? ;D


#11

Using your browser (IE or FF - Chrome won’t run games locally) run the index.html file found in your \mygame folder. Once loaded, you can bookmark it / add to Top Sites / Speed Dial or whatever, as you would for any web site.

The quickest way to re-run the game (e.g. after making changes to a scene file) is to simply click in the browser’s address bar and hit enter.


#12

Thanks! Now I ran into a series of new problems. I will first try to figure them out on my own before dropping it on you guys again.