Quicktest Error: Couldn't open


#1

I have a problem with Quicktest.

I’m trying to run it on the latest version of Choicescript. It has passed startup.txt with no problem. It then tries to load earth2090b.txt and I get the error message: ERROR: couldn’t open earth2090b.txt

The file earth2090b.txt is in the correct folder as always and I am able to load and playtest the game.

I am using Firefox for testing and it has always worked previously in older versions of quicktest.

Possible errors:
-The file is large at 607kb.
-the latest version of quicktest might have an error.

Can anyone help as quicktest is so important for finding errors!


#2

Unlikely, but worth a check: is your capitalization consistent?


#3

I did think that might affect it. The file name hasn’t changed, and is capitalised correctly. However I can’t see the .txt extension - it’s possible that it is .TXT and that is causing the issue. It’s never been a problem before but was an issue with Dashingdon.com (for images, not txt files).

Edit: by capitalised correctly I mean it is all lower case, the same as the request in quicktest.
I’ve tried to see the .txt extension but can’t find a way to display it. Properties tell me it is a Text Document (.txt) so I’m assuming that is correct.

The game itself runs perfectly through Firefox, including the earth2090b.txt file


#4

What format is your text file saved in?


#5

It’s just a standard text file. Nothing fancy. The same file I’ve been using and working on since 2013 with no problems. I updated choicescript a couple of days ago and now Quicktest doesn’t work.

The old version of quicktest still works perfectly. It’s changing to the new version that is causing errors.


#6

How are you calling it? Just *goto_scene earth2090b? Or is it something like *goto_scene {var}, or using *goto_random_scene or something? And is it in the *scene_list?


#7

The first one. It’s the same code from 2013 that’s worked fine until now.

Edit: I can play the game in the new choicescript. I just cant quicktest

Edit 2: Randomtest also works fine.


#8

Have you tried testing the new quicktest with a generic text file and startup just to see if it works?


#9

It works fine with the default files.


#10

earth2090b is the first file not listed in the scenelist (I actually don’t plan to use a scenelist with this game as goto_scene is more efficient). Have the requirements for this changed with this version of choicescript?

Note: The game still runs perfectly well in the new version of choicescript. It is only quicktest that isn’t working.

Edit: Yep, that’s it. As soon as I added earth2090b to the scene_list it worked, then failed on the next unlisted scene.
I’d say that’s an error with quicktest as surely the scene_list isn’t a requirement now…


#11

You don’t have to rely on the game to use the scene list naturally…
Just have the scene list contain all the names of your scene files so quicktest is happy, and use goto_scene whenever you like.


#12

Yep, I’ve added them all in. It’s totally redundant and never been necessary before. I’d love to know why it’s been changed. Surely an error?


#13

Scene list is used for a bunch of publication tasks. When you don’t include a scene list, all that happens is I have to do it before publishing. (Although I guess yeah, the error should be clearer.)