Problems entering files for contest--suggestions?

I had problems with my game and have used the randomtest and quicktest several times in Firefox to find and fix errors, including prior to using the submit form on the website. However, when I tried to use these two tools on the website, I received an error message for the first file that begins the character’s story.

I checked the game again on Firefox, no problems found. When I return to the website, the problem continues. I cannot go beyond the first page to do the test and finish my package.

I tried to enter via email as per instructions, but the files are two large for two of my email providers.

What should I do? I’m not giving up until the very last second to enter this contest!

Thank you.

1 Like

What error or errors was it giving you?
Also, how big are your files?

Well, the first thing I would suggest is emailing the contest help team at Hopefully they can suggest an alternative meathod for submitting the game.


Run Quicktest QUICKTEST FAILED: ERROR: couldn’t open robertstory.txt
Run Randomtest 10 times RANDOMTEST FAILED: Error: Couldn’t open web/mygame/scenes/RobertStory.txt

This is the file that starts the game.

I will now. I was hoping someone could help first here.

Thank you.

Sounds like you need to debug your game.

But post your *scene_list here.

the thing is case sensitive.
Put everything in lowercase (throughout the game and the filename) and it should work.
Good luck

I got the email you sent via the form, but you didn’t include a reply-to. I sent you a DM.

I had a similar problem but it ended up (seemingly) having something to do with the number of indents I had within an *if statement. It worked fine in Firefox, but when I tried to run it in the submission page it gave me an error.

Instead of just doing *if statements inside of *if statements, I ended up putting a *goto where the *if statement would be and dropping a label to a good location near the bottom.

Edit: I remember now. The error was about having to end an indentation in a *choice with either *finish or *goto. Even though mine all did, I rearranged it and it worked.

I’m not sure if this is what you’re experiencing, but maybe it will help someone else.

You know, some of my files are mix, caps with small letters. That may have something to do with it. Thanks for responding

I don’t know why my email would be missing the reply-to, but thanks for try8ing to help.

Thank you. Someone else suggested the same thing.

The final error you got is the same I did, but I didn’t understand what it meant. I usually finish with a *finish to move to next chapter or *goto_scene to move to continue the scene with next page. Confusing.

Just out of curiousity:
Have you yet tried

*finish text here


*page_break text here

For individualized next/next chapter buttons?

No. I was going by the sample in the original downloaded zip. That was working excepted sometimes I wouldn’t get a next chapter for *finish and I just let it go.

linking this again :slight_smile:

finish, in short looks for the next file on the scene list.
So if there’s no file on there, it has nowhere to go

1 Like


I understand how *finish works, so when I sent my files through quick test, I those missing text files were automatically found; but thanks for commenting. :slight_smile:

Ah :slight_smile: hope you didn’t feel offended Dx we had people a bit at a loss about what to do with the scenelist etc already.

Nope. I didn’t, that’s why I come here. I’ve gotten a lot of good help during this last year from the forum. I so appreciate people willing to monitor and respond so quickly to questions.

1 Like